Nombre trop important d'arguments pour cette fonction [Résolu]

Signaler
Messages postés
5
Date d'inscription
vendredi 10 juillet 2020
Statut
Membre
Dernière intervention
9 septembre 2020
-
Messages postés
5
Date d'inscription
vendredi 10 juillet 2020
Statut
Membre
Dernière intervention
9 septembre 2020
-
Bonjour

Cela fait un moment que j'essaye de résoudre un problème excel mais rien n'y fait.
J'ai la formule suivante qui me donne le message en objet de ce post:
=SI(ET(C2<>"-";EXACT(GAUCHE(I2);"M"));0;RECHERCHEV(I2;'[pricelist interne_2020_rev 2.xlsx]Price List CY20'!$M$11:$O$3001;3;FAUX);
SI(ET(D2<>"-";EXACT(GAUCHE(I2);"M"));0;RECHERCHEV(I2;'[pricelist interne_2020_rev 2.xlsx]Price List CY20'!$M$11:$O$3001;3;FAUX)))

Mon besoin est le suivant:
Si C2 est différent de - et I2 commence par M alors 0 sinon va chercher le montant dans pricelist interne...
Si D2 est différent de - et I2 commence par M alors 0 sinon va chercher le montant dans pricelist interne...

Il peut y avoir aussi des - dans C2 et dans D2 et dans ce cas il faut aller chercher le montant dans pricelist interne... Je ne sais pas s'il faut ajouter cet argument.
J'ai choisi la fonction SI ET mais manifestement ce n'est pas correct et peut-être que ce n'est pas non plus approprié.

Merci d'avance pour votre aide :)

1 réponse

Messages postés
25298
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2020
5 477
bonjour
votre premier SI s'arrête après le 1° recherche puisque vous lui donnez deux options, 0 ou RECHERCHEV
si la formule de recherche est bien la même dans les deux conditions, écrivez:

=SI(OU(ET(C2<>"-";EXACT(GAUCHE(I2);"M"));ET(D2<>"-";EXACT(GAUCHE(I2);"M")));0;RECHERCHEV(I2;'[pricelist interne_2020_rev 2.xlsx]Price List CY20'!$M$11:$O$3001;3;FAUX))

crdlmnt
Messages postés
5
Date d'inscription
vendredi 10 juillet 2020
Statut
Membre
Dernière intervention
9 septembre 2020

Je suis désolée je n'avais pas eu le temps de revernir vers vous.
Merci beaucoup pour cette aide précieuse.
Excel a encore bien des secrets pour moi.