Trop d'arguments sur une fonction Excel ??

Fermé
Kopros Messages postés 597 Date d'inscription mardi 25 septembre 2007 Statut Membre Dernière intervention 3 février 2020 - 15 déc. 2009 à 21:53
Raymond PENTIER Messages postés 58378 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 14 avril 2024 - 16 déc. 2009 à 01:18
Salut à tous !

Tout d'abord je tiens à signaler que je suis un noob sur excel.
J'ai fait cette fonction :
=SI(H5>19;SI(J5="x";"";SI(L5="";SI(M5="";"x";"");"");"")

Et là Exel 2003 me dit que j'ai mis trop d'arguments pour cette fonction.
J'ai lu qu'on pouvait mettre jusqu'à 7 SI imbriqués, en tout moi j'en ai que 4...
Comment faire pour que ça passe ?

Merci d'avance.

3 réponses

dobo69 Messages postés 1587 Date d'inscription vendredi 24 juillet 2009 Statut Membre Dernière intervention 30 juin 2013 821
15 déc. 2009 à 22:29
bonsoir,

la fonction SI fonctionne de la façon suivante (important pour les imbrications) :
=SI(test;'valeur si vrai';'valeur si faux')
une imbrication se fait en mettant d'autres fonctions SI "à la place" d'une des deux valeurs :
=SI(test1,'valeur1 si vrai';SI(test2;SI(test3;valeur3 si vrai';'valeur3 si faux');valeur2 si faux')) par exemple
il faut donc faire très attention aux ) notamment...
En l'occurrence, il y en un de trop et cette fonction donnera un résultat écrite sous cette forme :
=SI(H5>19;SI(J5="x";"";SI(L5="";SI(M5="";"x";"");""));"")
Cependant, ce n'est pas pour autant qu'il s'agit du "bon" résultat escompté : cela dépend de la bonne analyse du déroulement logique des SI, ALORS, SINON...
3