Nombre trop important d'arguments pour la fonction

Résolu/Fermé
kardeyo
Messages postés
7
Date d'inscription
mardi 17 janvier 2017
Statut
Membre
Dernière intervention
12 septembre 2022
- 17 janv. 2017 à 15:17
kardeyo
Messages postés
7
Date d'inscription
mardi 17 janvier 2017
Statut
Membre
Dernière intervention
12 septembre 2022
- 17 janv. 2017 à 16:02
Bonjour,
Voici la formule que j'ai encodée (euh je suis vraiment néophyte hin :p, j'ai mis plus d'une heure à trouver comment faire cette formule en lisant qlq forum ) :

=SI(AA20>85/100;"A";SI(ET(AA20<=84/100;AA20>=70/100);"B");SI(ET(AA20<=69/100;AA20>=50/100);"C");SI(AA20<=49/100;"D"))

et Excel m'indique un message d'erreur "nombre d'arguments trop important pour la fonction".
Ce que je souhaite c'est qu'au départ de ma cellule contenant une moyenne (AA20), excel m'indique
- soit que pour un résultat au-delà de 85% c'est A,
- soit que soit pour un résultat entre 84% et 70% c'est B,
- soit que pour un résultat entre 69% et 50% c'est C
- et enfin soit que pour un résultat égal ou inférieur à 49% c'est D.

Ai-je fait une erreur ?
Merci pour votre aide ;-)
A voir également:

5 réponses

diablo13800
Messages postés
2827
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
20 septembre 2022
1 793
Modifié par diablo13800 le 17/01/2017 à 15:34
Bonjour,

Bon , déjà on va simplifier votre formule , ca aidera à lire un petit peu:

=Si(AA20>85%;"A";Si(AA20>70%;"B";Si(AA20>50;"C";"D")))

Sinon Oui vous avez fait une erreur. Vous avez fermez des parenthèses beaucoup trop tôt .
Je met en gras les Parenthèses à retirer et je souligne celle à rajouter:).

=SI(AA20>85/100;"A";SI(ET(AA20<=84/100;AA20>=70/100);"B");SI(ET(AA20<=69/100;AA20>=50/100);"C");SI(AA20<=49/100;"D"))))


Normalement avec ça, pas d'erreur de Excel

Dites moi si c'est bon pour vous
0