Nombre trop important d'arguments pour la fonction [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
mardi 17 janvier 2017
Statut
Membre
Dernière intervention
17 janvier 2017
-
Messages postés
5
Date d'inscription
mardi 17 janvier 2017
Statut
Membre
Dernière intervention
17 janvier 2017
-
Bonjour,
Voici la formule que j'ai encodée (euh je suis vraiment néophyte hin :p, j'ai mis plus d'une heure à trouver comment faire cette formule en lisant qlq forum ) :

=SI(AA20>85/100;"A";SI(ET(AA20<=84/100;AA20>=70/100);"B");SI(ET(AA20<=69/100;AA20>=50/100);"C");SI(AA20<=49/100;"D"))

et Excel m'indique un message d'erreur "nombre d'arguments trop important pour la fonction".
Ce que je souhaite c'est qu'au départ de ma cellule contenant une moyenne (AA20), excel m'indique
- soit que pour un résultat au-delà de 85% c'est A,
- soit que soit pour un résultat entre 84% et 70% c'est B,
- soit que pour un résultat entre 69% et 50% c'est C
- et enfin soit que pour un résultat égal ou inférieur à 49% c'est D.

Ai-je fait une erreur ?
Merci pour votre aide ;-)

5 réponses

Messages postés
2216
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
3 juillet 2020
1 106
Bonjour,

Bon , déjà on va simplifier votre formule , ca aidera à lire un petit peu:

=Si(AA20>85%;"A";Si(AA20>70%;"B";Si(AA20>50;"C";"D")))

Sinon Oui vous avez fait une erreur. Vous avez fermez des parenthèses beaucoup trop tôt .
Je met en gras les Parenthèses à retirer et je souligne celle à rajouter:).

=SI(AA20>85/100;"A";SI(ET(AA20<=84/100;AA20>=70/100);"B");SI(ET(AA20<=69/100;AA20>=50/100);"C");SI(AA20<=49/100;"D"))))


Normalement avec ça, pas d'erreur de Excel

Dites moi si c'est bon pour vous
Messages postés
9498
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
10 juillet 2020
1 859
Bonjour

Il doit au minimum te manquer deux )) à la fin
tu as aussi un pb entre 49% et 50%
essaie ceci qui est plus simple
=SI(A2<50%;"D";SI(A2<70%;"C";SI(A2<85%;"B";"A")))

Cdlmnt
Messages postés
5
Date d'inscription
mardi 17 janvier 2017
Statut
Membre
Dernière intervention
17 janvier 2017

Parfait :-)
Merci ccm81, ça fonctionne ainsi. C'est super
Bonjour kardeyo,
Avec ta moyenne en AA20, je te propose cette formule :
=CAR(68-(AA20>49%)-(AA20>69%)-(AA20>84%))
albkan
Messages postés
5
Date d'inscription
mardi 17 janvier 2017
Statut
Membre
Dernière intervention
17 janvier 2017

merciiii :-)
Messages postés
5
Date d'inscription
mardi 17 janvier 2017
Statut
Membre
Dernière intervention
17 janvier 2017

Merci pour votre réponse rapide diablo13800 ;-)

Je viens de faire un copié-collé de la formule "raccourcie" que vous avez écrite

=Si(AA20>85%;"A";Si(AA20>70%;"B";Si(AA20>50;"C";"D")))


Elle ne doit pas être correcte car une moyenne de 85% me donne la lettre B or cela devrait être A, tout comme la moyenne de 54% me donne la lettre D or cela devrait être un C.

1) plus grand ou égal à 85¨% = A
2) entre 70 et 84% = B
3) entre 50 et 69 % = C
4) plus petit ou égal à 49% = D

Je ne suis pas très calée mais cela ne vient pas du fait que dans formule il manque les = ? Je m'explique AA20>85% ça ne devrait pas être AA20>=85% ? Je ne sais pas si je suis claire ...
Hello kardeyo,
Vu que B est pour entre 70% inclus et 84% inclus, A est pour >=85% donc >84%.
La formule très courte de mon message #3 tient compte de cela.  :)
Messages postés
2216
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
3 juillet 2020
1 106
Bon .

Exact , il manque juste les = suivant où vous les voulez:) Selon ce que vous dites votre formules doit être ça :

=Si(AA20>=85%;"A";Si(AA20>=70%;"B";Si(AA20>=50%;"C";"D")))

Ho ... et j'avais oubliez un pourcentage aussi... Faute d'inattention
Messages postés
5
Date d'inscription
mardi 17 janvier 2017
Statut
Membre
Dernière intervention
17 janvier 2017

Merci à tous pour vos réponses :-)
ça fonctionne maintenant ;-)