Compter le nombre de valeurs uniques avec plusieurs conditions [Fermé]

Signaler
-
Messages postés
25210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 août 2020
-
Bonjour,

Notre fichier excel qui contient les données sources se compose de 4 colonnes (Nom de la société, date de transaction, ID de la personne, Statut de la personne).


Par exemple nous avons dans chaque colonne:
Nom de société: Carrefour, Auchan, Hyper U, Leclerc ect...
Date: 2014, 2015, 2016
Id de la personne: "code à chiffre"
Statut de la personne: Silver, Gold, Platinium


Ensuite, dans un autre onglet, nous avons créé un tableau dans lequel on calcule le nombre de transaction chez X, à date T et dont les personnes ont un statut S.
Pour cela, nous avons utilisé la formule : (exemple)
=NB.SI.ENS(Tableau2[SOCIETE];"Carrefour";Tableau2[DATE];"2016";Tableau2[STATUT];"Gold")


J'aimerai cette fois ci connaitre le nombre unique de personne qui ont effectué une transaction en 2016, chez Carrefour et ayant le statut Gold.

C'est le caractère unique qui nous bloque. (car certains ID apparaissent plusieurs fois = plusieurs transactions pour une même personne)


Enfin, notre excel contient ENORMEMENT de données, c'est pour cela que nous ne pouvons pas utiliser les fonctions filtres et cherchons à utiliser des fonctions (plus automatique)


On a essayé d'utiliser la fonction =SOMME(SI(FREQUENCE(F2:F36;F2:F36)>0;1)) cependant cela ne prend pas en compte les critères dans les autres colonnes.
Et je ne sais pas comment l'associer à la fonction NB.SI.ENS (si cela est possible).


je compte donc sur votre aide en excel pour résoudre ce case tête :)

Merci d'avance,

Tris.



2 réponses

Messages postés
1505
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
125
Bonsoir,

as-tu essayé la formule somme.prod ?

je pense que cela pourrait résoudre ton problème.
Voici un tuto qui explique comment la formule fonctionne :

http://www.bernardcordier.com/excel_sommeprod.htm
Messages postés
25210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 août 2020
5 392
Bonjour
je pense que le plus simple serait de créer, sur la base de données ou une autre feuille, une colonne qui concatène les informations souhaitées

avec =cell société&cell date &cell statut

tirée sur la hauteur utile et d'adapter cette formule dans une cellule à ce champ pour détecter combien il y a de libellés différents

=SOMME(SI(B2:B38<>"";1/NB.SI(B2:B38;B2:B38)))

attention formule matricielle à entrer avec la touche enter en maintenant les touches ctrl et shift enfoncées. elle s'affiche automatiquement entre accolades dans la barre de formule

crdlmnt