Formule comprise entre 2 valeurs./Excel [Résolu/Fermé]

Signaler
Messages postés
71
Date d'inscription
vendredi 2 avril 2010
Statut
Membre
Dernière intervention
14 mai 2010
-
 lamine -
Condition comprise entre deux valeurs
J'ai un tableau avec 2 colonnes montants facture et Remise
Si le montant est inférieur à 1000$...taux 0
SI le montant comprise entre 1000 $ et 1500$ ....taux de remise est 1%
SI le montant est comprise entre 1500 et 3000......taux de remise est 2 %

Voici la formule que j'ai tapé

=SI(B2<1000;B2*0;SI(1000=<B2<1500;B2*0.01;SI(1500=<B2<3000;B2*0.02;)))

Dans le tableau la 1ère valeur est affichée correct mais la suite FAUX s'affiche où 0.

2 réponses

essaie ça :

=SI(B2<1000;B2*0;SI(B2<1500;B2*0.01;SI(B2<3000;B2*0.02;))) 


sinon tu 'as toujours la possibilité d'utiliser la fonction ET mais dans une formule, il ne faut jamais mettre 2 comparaison dans la même validation.

Dans la formule que je te propose, si c'est faux que le montant est plus petit que 1000, tu n'as donc plus besoin de tester dans le futur s'il est plus grand que 1000 dans la deuxième étape de ta formule. Et s'il n'est pas plus petit que 1500, pas besoin de tester non plus si le montant est entre 1500 et 3000.
49
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57041 internautes nous ont dit merci ce mois-ci

Messages postés
71
Date d'inscription
vendredi 2 avril 2010
Statut
Membre
Dernière intervention
14 mai 2010

oui ça marche ..merci bcp mon cerveau .Ton raisonnement est logique je sais si le montant est inférieur à 1000, pas la peine de conditionner ensuite entre 1000 et 1500..
logique si 999 taux = 0, si 1000 jusqu 1500 taux 1 %
.mais je veux savoir comment utiliser la forumule ET avec les mêmes données par exemple entre 1000 et 1500
car c'est différent de préciser que le montant est <1000 et <=1000..
II- dans la même formule Excel n'accepte pas par exemple la formule B2*0.01 et la corrige en B2*1/100.....bizarre
.
Merci bcp, très utile !
Messages postés
52045
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 793
Bonjour.
1) Compte tenu du problème à résoudre, la fonction ET ne se justifie pas ; ça ne ferait que compliquer la formule :
=SI(ET(B2>1000;B2<1500);B2*0.01;SI(B2<3000;B2*0.02;0))
2) Mettre <= au lieu de =<
3) Multiplier par un centième ou diviser par 100, c'est la même chose ; B2*0.01 ou B2*1/100 ou B2/100 sont identiques ; laisse donc Excel utiliser ses formats favoris ...
Messages postés
71
Date d'inscription
vendredi 2 avril 2010
Statut
Membre
Dernière intervention
14 mai 2010

Merci bcp cela fonctionne c'est vrai c'est compliqué cette histoire ET...la formule que m'a donné Cameliar est logique et simple.
Cdt
The Predator