Nombre de valeurs uniques selon 2 conditions [Fermé]

Signaler
Messages postés
2
Date d'inscription
mercredi 23 mars 2016
Statut
Membre
Dernière intervention
23 mars 2016
-
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
-
Bonjour,

J'ai beau essayer de reproduire les formules que je trouve sur les forums, mais rien ne marche!
Voilà mon problème:
j'ai dans colonne A: des noms d'OP
colonne B: la commune dans laquelle se situe l'OP
colonne C: la région de cette OP
Dans une même commune, on retrouve plusieurs fois la même OP
Il peut y avoir 2 OP au même nom dans des communes différentes
Je voudrais récupérer le nombre d'OP différentes de la région 1, de préférence sans passer par une colonne supplémentaire ni VBA, car le tableau est amené à être complété régulièrement (il y a beaucoup de lignes et on en rajoute toujours)

Exemple:
col A col B col C
AINGA Miarinavaratra Amoron'i Mania
AINGAVAO Miarinavaratra Amoron'i Mania
Aingavao Marosoa Amoron'i Mania
Aingavao Marosoa Amoron'i Mania
akoho gasy Marosoa Amoron'i Mania
AVOTRA Miarinavaratra Amoron'i Mania
EZAKA Miarinavaratra Amoron'i Mania
EZAKA Ambatomarina Amoron'i Mania


je voudrais récupérer la valeur 7, car il y a 7 OP différentes : les 2 "aingavao" de la commune Marosoa ne valent qu'1. Les mêmes valeurs de la colonne A ne sont pas considérées comme des doublons si elles ont une valeur en colonne B différente (si elles sont d'une commune différente)
je ne peux pas supprimer les doublons du tableau, car c'est un tableau de suivi de formations réalisées

Merci d'avance pour votre aide!

2 réponses

Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
15
Bonjour,

Essayez cette méthode :

En Colonne D:D, vous ajoutez cette formule à étirer vers le bas :
=A1&";"&B1&";"&C1

En Colonne E:E, vous ajoutez cette formule à étirer ves le bas :
=NB.SI(D$1:D1;D1)

Puis dans la cellule où vous souhaitez afficher le résultat, vous entrez la formule suivante:
=SOMME.SI(E:E;1)


Cdt,
Messages postés
2
Date d'inscription
mercredi 23 mars 2016
Statut
Membre
Dernière intervention
23 mars 2016

Bonjour Theo.R

Quelle réactivité!
Merci beaucoup pour votre aide (même si j'aurais préféré ne pas avoir à rajouter de colonnes, mais ça n'est peut-être pas possible). J'ai juste modifié la dernière formule par: somme.si.ens(E:E;E:E;1;C:C;"Amoron'i Mania").

Merci encore,
Cdt
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
15
Je ne vois pas d'autre solution par formule désolé :s, vous pouvez masquer les colonnes de calcul ou les mettre plus loin dans le document.

Bonne continuation,