Valeurs uniques avec critère [Fermé]

Signaler
-
 Poulbec -
Bonjour,
Je cherche un moyen de résoudre ce problème:
difficile à expliquer je mets un exemple!!
Dupont Michel 1enfant en terminale à Lyon
Dupont Michel 1 enfant en seconde à Lyon
Duprat Xavier 1 enfant en 3eme a Paris
Leclerc Paul 1 enfant en 6eme à Paris
Encore Françoise 1 enfant en 4eme à Lyon

Voilà je dois trouver le nombre de famille ayant un enfant au moins à Lyon...
dans cet exemple la réponse serait 2 familles
mais comment enlever les doublons dans la colonne de base?
merci d'avance


5 réponses

Messages postés
17159
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 août 2020
4 167
Bonjour,

plusieurs possibilités, tout dépend comment tu as créé ta base de données

si tu as un colonne exemple A avec nom et prénom, en B le nombre d'enfant et en C la ville
si tu ne dois compter que lorsque tu n'as qu'un enfant cette formule suiffit
=SOMMEPROD((C2:C20="Lyon")*(B2:B20=1))

maintenant je te conseille d'utiliser plutôt
=SOMMEPROD((C2:C20="Lyon")*(B2:B20=1)*(B2:B20<>""))

si tu dois compter avec d'autres critères tu peux placer les critères de recherche dans des cellules exemple la ville en F1 et le nombre d'enfant en G1
la formule devient
=SOMMEPROD((C2:C20="F1")*(B2:B20=G1)*(B2:B20<>""))
et si tu nommes tes plages exemple C2:C20 nommée Ville etc
la formule devient
=SOMMEPROD((Ville=F1)*(Enfant=G1)*(Enfant<>""))
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 395
Bonjour
sans savoir comment sont organisées vos données, ça va être difficile de vous répondre! est ce que ce sont des textes dans une seule cellule ou des infos en différentes colonnes?
Mike, salut, je crois comprendre que Poulbec ne veux compter qu'une seule fois les familles qui ont plusieurs enfants à Lyon comme dans son exemple avec Dupont Michel

En attente de réponse

crdlmnt
>
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020

Bonjour à vous deux et merci d'avoir pris le temps de répondre tout d'abord! :)
voila comment ca se présente:
nom et prénom dans une colonne, nbr d'enfant a charge dans une autre et classe et lieu de l'enfant dans une troisième

colonne A --->Nom Prénom
colonne B --->nb d'enfant a charges
colonne C--> classe de l'enfant et lieu
ex:
Dupont Michel // 3 // terminale à Lyon
Dupont Michel // 3 //seconde à Lyon
Duprat Xavier // 1 // 3eme a Paris
Leclerc Paul // 2 // 6eme à Paris
Ecore Françoise // 1 // 4eme a Lyon

ce qui me pose problème est qu'il y a 2 critères de sélection . En fait j'utilisais NB SI ENS mais ducoup les familles avec plusieurs enfants étaient comptés en plusieurs fois...avec somme prod j'ai essayé mais je n'arrives pas à mettre en place la formule.

sachant que il s'agit d'un code pour la classe et la ville par exemple 01LY pour première à Lyon ducoup il faut mettre "**LY" pour éviter de mettre une formule pour chaque classe

merciiiii d'avance
Messages postés
17159
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 août 2020
4 167
Salut Vaucluse,

Ah oui tu as raison
Messages postés
17159
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 août 2020
4 167
Re,

L'ami Vaucluse avait bien vu, en colonne D en D1 copie cette formule
=SI(NB.SI(DECALER($A$2;0;0;LIGNE()-1);DECALER($A$2;LIGNE()-1;0))>0;"";1)
et incrémente la vers le bas, plus tard tu pourras masquer cette colonne
ensuite utilise cette formule
=SOMMEPROD((C2:C50="lyon")*(B2:B50=1)*(D2:D50=1)*(B2:B50<>""))

il est possible d'utiliser un filtre automatique sur les quatre colonne A, B, C et D
et cette formule
=SOUS.TOTAL(3;A3:A50)


Je teste ça demain au travail et je vous tiens au courant! merci beaucoup en tout cas :)
Messages postés
17159
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 août 2020
4 167
Re,

télécharge le fichier exemple pour t'aider à comprendre les diverses formules sont dans les cellules colorisées
https://www.cjoint.com/c/FFwtZdE8Kyj
bonjour Mike! merci encore! sais tu comment joindre un fichier excel?
Messages postés
17159
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 août 2020
4 167
Re,

pour joindre un fichier
1) Clic sur ce lien https://www.cjoint.com/
2) Clic sur le bouton Parcourir pour sélectionner ton fichier
3) Clic sur le bouton Créer le lien en bas de la page
4) Au bout de quelques secondes en haut de la page en bleu souligné un lien sera généré, tu le sélectionnes et tu le copies dans une réponse

http://www.cjoint.com/c/FFxhgzcWgAs
voici le fichier :)
bonjour à tous!
j'ai finalement trouvé une solution au problème en extrayant une liste sans doublons de noms sur une autre feuille excel!(données/filtrer/avancé/extraction à un autre emplacement/extraction sans doublons) Dès que j'en avais besoin je m'y referait et non à la feuille source comportant tout les noms!
encore merci à tous
Cdlt
Poulbec