Xdcmp mandriva problème de réseau [Fermé]

Signaler
Messages postés
673
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
6 juin 2017
-
 I4U -
Bonjour à tous.
JE viens de configurer xdmcp sur une mandriva 2008.1 afin de pouvoir ouvrir une session à distance. Pour configurer le serveur j'ai suivie ce tuto
http://wiki.mandriva.com/ Pour faire plus rapide ce tuto propose :

Éditez le fichier /etc/kde/kdm/kdmrc A la section [Xdmcp], modifiez "Enable=false" comme suit:

Enable=true

Éditer /etc/X11/xdm/xdm-config et commentez la ligne suivante :

! DisplayManager.requestPort: 0


Dans mon cas j'ai ouvert le port 177 sur le serveur (j'ai aussi ajouté port=177 dans la section Xdmcp du fichier kdmrc).
J'ai ensuite redémarrer tous le système.

Mon problème est que je n'arrive pas à y accéder de mon autre PC (client mandriva 2008.1) connecté sur le même réseau sur lequel le port 177 est aussi ouvert. Il m'affiche aucune connexion possible sur le réseau et quand je rentre l'IP du serveur X11 se relance puis écran noir(pas de pront) avec la souris au milieu de l'écran.

voilà ma configuration réseau :

serveur (192.168.0.10/255.255.255.0)->(192.168.0.1/255.255.255.0neuf box)<-client(192.168.0.4/255.255.255.0)

Les deux pc sont relié à la neuf box mais pas directement entre eux.
Merci de votre aide.

2 réponses

Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
110
Salut,

si mes souvenirs sont bons et si ça n'a pas changé depuis, xdcmp utilise le port 177 en UDP et le port 6000 en TCP.

Regarde de ce coté la
Messages postés
673
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
6 juin 2017
41
Salut.
J'ai en fait un problème de réseau je pense. J'ai testé avec nmap et les port TCP sont bien ouvert du serveur au client et du client au serveur. Pour les ports UDP, le port est ouvert du serveur au client mais pas du client au serveur. voila le résultat :
# nmap -sU 192.168.0.10
Starting Nmap 4.53 ( https://insecure.org/ ) at 2008-09-21 11:28 CEST
All 1488 scanned ports on 192.168.0.10 are open|filtered
MAC Address: 00:1E:8C:D6:25:74 (Asustek Computer)

Nmap done: 1 IP address (1 host up) scanned in 32.567 seconds


Le problème peut il venir de ma neuf box? Le serveur et connecté sur la prise TV configuré en mode réseau.
Merci de votre aide.
Je me demande s'il ne faut pas une carte réseau double: une pour l'accès internet, l'autre pou le réseau.