Connexion phpmyadmin impossible

Fermé
frederic farlay
Messages postés
3
Date d'inscription
samedi 10 mars 2007
Statut
Membre
Dernière intervention
16 mars 2007
- 10 mars 2007 à 22:21
 chadowboy - 30 mai 2017 à 15:39
bonsoir

j'ai voulu mettre un mot de passe pour root et depuis lorsque je lance l'administration et que je clique sur le phpmyadmin j'ai le message suivant

MySQL a répondu:
#1045 - Acc�s refus� pour l'utilisateur: 'root'@'@localhost' (mot de passe: NON)

le probleme c'est que je n'ai plus acces à rien

quelqu'un aurait-il une soluce ?
Merci
Fred
A voir également:

6 réponses

jujuzilla
Messages postés
3
Date d'inscription
mercredi 13 février 2008
Statut
Membre
Dernière intervention
13 février 2008
241
13 févr. 2008 à 03:39
un peu tard mais je viens d'avoir eu le pb en installant wamp5

#1045- Access denied for user ‘root’@localhost’

Pour ceux qui ont un problème d’ouverture de PhpMyAdmin avec Access Denied :

#1045- Access denied for user ‘root’@localhost’

Il est nécessaire d’effectuer quelques manipulations après l’installation :

Ouvrez la console MySql,

Après avoir tapé Entrée et avoir la commande mysql> :

Il est utile de commencer par attribuer le nouveau mot de passe via la commande :

SET PASSWORD FOR root@localhost=PASSWORD(' monmotdepasse ');

Ensuite il n’est pas inutile de réattribuer les droits de super utilisateur via la commande :

mysql> GRANT ALL PRIVILEGES ON *.* TO root@localhost
-> IDENTIFIED BY ' monmotdepasse ' WITH GRANT OPTION;

Bien évidemment il faut insérer les noms de host et de compte user par défaut avec le mot de passe mis en place dans le fichier ‘php.ini’, au niveau suivant :

; Default host for mysql_connect() (doesn't apply in safe mode).
mysqli.default_host ='localhost'

; Default user for mysql_connect() (doesn't apply in safe mode).
mysqli.default_user ='root'

; Default password for mysqli_connect() (doesn't apply in safe mode).
; Note that this is generally a *bad* idea to store passwords in this file.
; *Any* user with PHP access can run 'echo get_cfg_var("mysqli.default_pw")
; and reveal this password! And of course, any users with read access to this
; file will be able to reveal the password as well.
mysqli.default_pw ='monmotdepasse'

Et il ne reste plus qu’à effectuer l’implantation des noms de host et de compte user par défaut avec le mot de passe dans le fichier ‘config.inc.php’ aux lignes suivantes:

$cfg['Servers'][$i]['host']= 'localhost';

$cfg['Servers'][$i]['user'] = 'root';

$cfg['Servers'][$i]['password']= 'monmotdepasse';

Et là après n’avoir pu seulement ouvrir correctement la page localhost, vous allez avoir l’agréable surprise de pouvoir vous connecter à PhpMyAdmin sans l’erreur :

#1045- Access denied for user ‘root’@localhost’


Cordialement,

Julien du 49.
26
merci beaucoup pour ton aide.
0
Oui, ça m'a bien dépanné aussi, merci...
0
salut, ce que tu as mis ma deja pas mal aidé mais je bloque parce que je trouve pas de dossier php.ini ... je sais pas si sa a un rapport mais moi jai telecharger wamp server
a bientot j'espere , ++
0
et pour une authentification sur l'index du server. tu fais comment?
0
pensez a modifier :
$cfg['Servers'][$i]['AllowNoPassword'] = true;

par
$cfg['Servers'][$i]['AllowNoPassword'] = false;
0