[Excel] NB.SI avec chaine de texte partielle [Résolu/Fermé]

Signaler
-
 LGLCNfamily -
Bonjour,

Je cherche à compter le nombre de cellule qui contienne un certain texte qui est une partie seulement de la valeur de la cellule. Exemple :
Cellule 1 : Marc est beau
Cellule 2 : Marc est riche
Cellule 1 : Sophie est belle

Je voudrais une formule qui me compte le nombre de cellule ou "Marc" apparait, ici 2. Il doit falloir bidouiller la fonction NB.SI mais je ne cois pas comment.

Merci de votre aide



1 réponse

Messages postés
25294
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2020
5 471
Bonsoir
=NB.SI(A1:A100;"*Marc*")

ou
=NB.SI(A1:A100;"*"&B1&"*")

en mettant en B1 le texte cherché
crdlmnt
84
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60386 internautes nous ont dit merci ce mois-ci


Ca a l'air de marcher, super ! Je connaissais pas ce truc avec les astérisques. Ca marche dans toute les formules Excel ?
En tout cas merci du tuyau
Messages postés
25294
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2020
5 471 > lecastorlapon
Bonjour lacastorlapon(!!?)

non, ça ne s'applique pas par exemple, avec les formules qui utilisent un opérateur mathématique tel que +, - > < en séparateur de champ

mais un uniquement via le point virgule
par exemple:
=SI(A1="*A*"... ne fonctionne pas

par contre:
RECHERCHEV("*A*";Champ... fonctionne. ainsi que EQUIV("*"&B1&"*";Champ)
idem avec SOMME.SI("*"&B1&"*";.....
Etc...

en complément et pour info
si vous écrivez
"*"& B1 ou "*texte", la formule ne recherche que le premier mot du texte
avec
B1&"*" ou "texte*" , avec le dernier mot
encadré par les deux astérisques, le code cherche n'importe ou dans le texte.

Bonne route

crdlmnt
> lecastorlapon
Nickel. En fait c'est comme un méta caractère, je m'en sers quand je fais des recherches Windows.

Sinon pour mono pseudo, ça vient de mon surnom (Castor) et d'un sketch des Nuls sur les Castors lapons.

@+

J'ai cherché des heures avant de trouver votre post. Merci !!!