[Excel] NB.SI avec chaine de texte partielle

Résolu/Fermé
lecastorlapon - 30 nov. 2011 à 17:28
 LGLCNfamily - 30 mars 2019 à 18:26
Bonjour,

Je cherche à compter le nombre de cellule qui contienne un certain texte qui est une partie seulement de la valeur de la cellule. Exemple :
Cellule 1 : Marc est beau
Cellule 2 : Marc est riche
Cellule 1 : Sophie est belle

Je voudrais une formule qui me compte le nombre de cellule ou "Marc" apparait, ici 2. Il doit falloir bidouiller la fonction NB.SI mais je ne cois pas comment.

Merci de votre aide



1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 252
Modifié le 25 janv. 2019 à 12:07
Bonsoir
=NB.SI(A1:A100;"*Marc*")

ou
=NB.SI(A1:A100;"*"&B1&"*")

en mettant en B1 le texte cherché
crdlmnt
99
lecastorlapon
1 déc. 2011 à 10:31
Ca a l'air de marcher, super ! Je connaissais pas ce truc avec les astérisques. Ca marche dans toute les formules Excel ?
En tout cas merci du tuyau
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 252 > lecastorlapon
Modifié par Vaucluse le 1/12/2011 à 12:59
Bonjour lacastorlapon(!!?)

non, ça ne s'applique pas par exemple, avec les formules qui utilisent un opérateur mathématique tel que +, - > < en séparateur de champ

mais un uniquement via le point virgule
par exemple:
=SI(A1="*A*"... ne fonctionne pas

par contre:
RECHERCHEV("*A*";Champ... fonctionne. ainsi que EQUIV("*"&B1&"*";Champ)
idem avec SOMME.SI("*"&B1&"*";.....
Etc...

en complément et pour info
si vous écrivez
"*"& B1 ou "*texte", la formule ne recherche que le premier mot du texte
avec
B1&"*" ou "texte*" , avec le dernier mot
encadré par les deux astérisques, le code cherche n'importe ou dans le texte.

Bonne route

crdlmnt
1
lecastorlapon > lecastorlapon
1 déc. 2011 à 17:04
Nickel. En fait c'est comme un méta caractère, je m'en sers quand je fais des recherches Windows.

Sinon pour mono pseudo, ça vient de mon surnom (Castor) et d'un sketch des Nuls sur les Castors lapons.

@+
0
LGLCNfamily
30 mars 2019 à 18:26
J'ai cherché des heures avant de trouver votre post. Merci !!!
0