Excel : si ma cellule contient tel texte ou tel texte

Résolu/Fermé
Valerieh34 Messages postés 13 Date d'inscription vendredi 20 février 2015 Statut Membre Dernière intervention 22 mai 2016 - 22 mai 2016 à 04:30
Valerieh34 Messages postés 13 Date d'inscription vendredi 20 février 2015 Statut Membre Dernière intervention 22 mai 2016 - 22 mai 2016 à 07:11
Bonjour à tous,

J'ai un léger souci que je souhaiterai pouvoir trouver par une formule.
Si ma cellule A1 contient le texte "ABC" alors écrire ABC en cellule B1 ou si ma cellule A1 contient le texte "123" alors ecrire 123 en B1.
Sachant que la première condition, je l'ai trouvé par la fonction en B1
=SI (NB.SI (A1;"*ABC*");"ABC";"")

Comment faire ?
Merci pour votre aide
Valerie
A voir également:

2 réponses

Frenchie83 Messages postés 2240 Date d'inscription lundi 6 mai 2013 Statut Membre Dernière intervention 11 août 2023 338
Modifié par Frenchie83 le 22/05/2016 à 05:34
Bonjour
=SI(NB.SI(A1;"*ABC*");"ABC";SI(OU(NB.SI(A1;"*123*");NB.SI(A1;"123*");NB.SI(A1;"*123");A1=123);123;""))
Cdlt
12
Valerieh34 Messages postés 13 Date d'inscription vendredi 20 février 2015 Statut Membre Dernière intervention 22 mai 2016 3
22 mai 2016 à 06:17
Merci
Ca semble se rapprocher de ce que je recherche
En fait, j'ai mal formulé ma question.
Jai en tout 10 possibilités
La case A1 peut contenir le caractère ABC ou 123 ou DEF ou ...
Dans la case B1, en fonction du type de caractère recherché, je dois l'y trouver
Encore merci si tu peux m'apporter la lumière
0
Valerieh34 Messages postés 13 Date d'inscription vendredi 20 février 2015 Statut Membre Dernière intervention 22 mai 2016 3
22 mai 2016 à 07:11
J'ai trouvé
=SI(NB.SI(A1;"*ABC*");"ABC";SI(NB.SI(A1;"*123*");123;SI (NB.SI (A1;"*DEF");"DEF";"X"))
Merci beaucoup pour votre aide
Cordialement
Valérie
3