Excel : si ma cellule contient tel texte ou tel texte [Résolu/Fermé]

Signaler
Messages postés
14
Date d'inscription
vendredi 20 février 2015
Statut
Membre
Dernière intervention
22 mai 2016
-
Messages postés
14
Date d'inscription
vendredi 20 février 2015
Statut
Membre
Dernière intervention
22 mai 2016
-
Bonjour à tous,

J'ai un léger souci que je souhaiterai pouvoir trouver par une formule.
Si ma cellule A1 contient le texte "ABC" alors écrire ABC en cellule B1 ou si ma cellule A1 contient le texte "123" alors ecrire 123 en B1.
Sachant que la première condition, je l'ai trouvé par la fonction en B1
=SI (NB.SI (A1;"*ABC*");"ABC";"")

Comment faire ?
Merci pour votre aide
Valerie

2 réponses

Messages postés
2165
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
11 octobre 2020
290
Bonjour
=SI(NB.SI(A1;"*ABC*");"ABC";SI(OU(NB.SI(A1;"*123*");NB.SI(A1;"123*");NB.SI(A1;"*123");A1=123);123;""))
Cdlt
6
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
14
Date d'inscription
vendredi 20 février 2015
Statut
Membre
Dernière intervention
22 mai 2016

Merci
Ca semble se rapprocher de ce que je recherche
En fait, j'ai mal formulé ma question.
Jai en tout 10 possibilités
La case A1 peut contenir le caractère ABC ou 123 ou DEF ou ...
Dans la case B1, en fonction du type de caractère recherché, je dois l'y trouver
Encore merci si tu peux m'apporter la lumière
Messages postés
14
Date d'inscription
vendredi 20 février 2015
Statut
Membre
Dernière intervention
22 mai 2016

J'ai trouvé
=SI(NB.SI(A1;"*ABC*");"ABC";SI(NB.SI(A1;"*123*");123;SI (NB.SI (A1;"*DEF");"DEF";"X"))
Merci beaucoup pour votre aide
Cordialement
Valérie
Messages postés
16596
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
9 798
Bonsoir,

En B1, tu mets la formule suivante :
=SI(A1="ABC";"ABC";SI(A1=123;123;""))

A titre d'info NB.SI permet de compter un nombre de cellules en fonction d'un critère, ce qui n'a rien à voir avec ta demande.

m@rina
Messages postés
14
Date d'inscription
vendredi 20 février 2015
Statut
Membre
Dernière intervention
22 mai 2016

Merci mais ce n'est pas ça car la cellule doit contenir et non pas être exactement celle-ci