Formule Excel : "SI" une cellule contient un mot, alors ?

Résolu
Tonio5933 Messages postés 4 Date d'inscription jeudi 27 juillet 2017 Statut Membre Dernière intervention 19 septembre 2017 - Modifié le 18 nov. 2021 à 09:15
 Dilou-31 - 8 nov. 2019 à 11:03
Bonjour à toutes et tous,

Je galère depuis plusieurs jours et n'ai trouvé aucune réponse sur les forums.

Voilà le problème:
J'ai en colonne A du texte (par exemple NOM PRENOM)
Je voudrais en colonne B mettre une formule qui me donne un résultat en fonction d'une partie du texte de A.
Exemple: si A1 contient "Fabien" ou "Franck" ou encore d'autres prénoms (environ 10 possibilités), alors ça me renvoie "élève", autrement, rien.

Suis-je assez clair pour que quelqu'un puisse m'aider ?

Merci d'avance pour vos tuyaux





Configuration: Windows / Firefox 54.0
A voir également:

2 réponses

Mike-31 Messages postés 18177 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 29 janvier 2023 5 033
Modifié le 17 janv. 2019 à 09:33
Bonsoir,

Une formule parmi d'autres

=SI(OU(NB.SI(A2;"*franck*");NB.SI(A2;"*michel*");NB.SI(A2;"*fabien*"));"élève";"") 


à toi d'ajouter des NB.SI(A2;"*franck*") sans oublier les étoiles
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
43
Tonio5933 Messages postés 4 Date d'inscription jeudi 27 juillet 2017 Statut Membre Dernière intervention 19 septembre 2017
27 juil. 2017 à 19:53
Merci Mike !
Je viens de tester, et visiblement ça fonctionne.
Je termine ma formule avec tout ce dont j'ai besoin et reviens vers vous si je retombe en panne !

Encore merci
0
Mike-31 Messages postés 18177 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 29 janvier 2023 5 033 > Tonio5933 Messages postés 4 Date d'inscription jeudi 27 juillet 2017 Statut Membre Dernière intervention 19 septembre 2017
27 juil. 2017 à 20:10
Re,

Ok pas de problème, de toute façon si ton problème est résolu n'oublie pas de mettre le statut de la discussion en résolu.
Cordialement
0
Bonjour,

J'ai besoin d'obtenir une formule:

Si dans ma colonne A réponse "NON" donner en colonne C la valeur écrite d'une cellule en colonne B.

Merci à tous
0
Bonjour,
J'avais un cas similaire. Cela marche parfaitement. Merci beaucoup!
Cordialement
0