Excel si cellule contient texte alors...

Résolu
caba_44 Messages postés 99 Date d'inscription lundi 14 décembre 2009 Statut Membre Dernière intervention 24 novembre 2022 - Modifié le 13 oct. 2021 à 17:39
 loly - 21 avril 2021 à 11:33
Bonjour à tous,

J'ai un léger soucis que je souhaiterais pouvoir faciliter par une formule.
Si ma cellule A1 contient le texte "NBR" alors écrire NBR en cellule B1
Sachant que la cellule A1 = O'Ring NBR 70 Shore A.

Comment faire ?

En attendant de vous lire,

Mathieu



Configuration: Windows Vista / Firefox 12.0

7 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
Modifié le 29 nov. 2018 à 17:12
Bonjour
en B1
=SI(NB.SI(A1;"*NBR*");"NBR";"")

attention aux signes
crdlmnt
378
caba_44 Messages postés 99 Date d'inscription lundi 14 décembre 2009 Statut Membre Dernière intervention 24 novembre 2022 5
10 mai 2012 à 14:24
Super ca fonctionne...

Je vous remercie pour votre retour

A très bientôt :)

Mathieu
2
Génial ! Je n'arrivais pas à trouver cette solution sur tous les sites anglohopnes sur excel...
Savez-vous comment faire pour multiplier les conditions?
0
Ricky38 Messages postés 4347 Date d'inscription samedi 15 mars 2008 Statut Contributeur Dernière intervention 2 novembre 2013 1 447
3 avril 2013 à 13:56
Salut,

regarde du coté des SI imbriqués
exemple: =SI(A1=1;"ok";SI(A1=2;"Super";SI(A1=3;"excellent";"")))
0
Super solution, j'aimerais juste comprendre pourquoi on utilise le nb.si dans ce cas.
J'ai essayé la même formule sans le nb.si et ca ne fonctionne pas.

Pouvez-vous m'epxliquer la logique derrière cette formule ? (le nb.si et normalement fait pour "compter" le nombre d'occures non ? :)
0
MERCIIIIIII !!!!!!!!! Au fin j'ai trouvé la solution pour m'aider :)
0