Java.lang.noclassdeffounderror [Résolu/Fermé]

Signaler
-
 zobbi_la_mouche -
Bonjour,

J'ai un problème à chaque fois que j'execute un programme Java en ligne de commandes : j'obtiens Java.lang.noclassdeffounderror ...
Qelqu'un a-t-il une solution,
merci d'avance
Véronique

35 réponses

il faut ajouter un CLASSPATHqui spécifie ou se trouve tes classes java.
Non, non, tout ça c'est correct : variable système JAVA_HOME c:\jdk1.3.1 et CLASSPATH pointe là ou il faut ...

d'autant plus que même avec un "hello World" qui ne fait appel à aucun package extèieur cela coince ?...
> Véronique
quel est le message exactement??
Salut tu es sur un forum et il existe ceratins mots qu'il ne faut pas utiliser "je m'en fiche de classpath et tout ..." c'est pas tres respectueux ni serieux ni poli...
Bonjour, j'ai le meme probleme j'ai lu toutes les reponces que vous donner mais j'ai rien compri est ce qu'il a une methode plus simple voilà la version de mon jdk "jdk1.6.0_03" et merci.
Bonjour,
J'ai exactement le même soucis, tout comme yassine, je ne trouve pas de solution à mon problème.
Pourtant mes variable CLASSPATH et JAVA_HOME pointent bien vers le bon dossier :/
J'ai aussi la version jdk1.6_03
Quelqu'un aurait une solution au problème?

Merci.
Bonjour,
J' ai eu le mm pb, il m' a suffit de désinstaller le jdk, d' installer la nouvelle version et de redéfinir les variable d' environnement.
ATTENTION les noms de CLASSES douvent être en MAJUSCULES c'est peut etre pr ça que ça ne marche pas.
Messages postés
4088
Date d'inscription
jeudi 7 avril 2005
Statut
Contributeur
Dernière intervention
30 septembre 2013
852
A priori je dirais qu'il te manque des librairies dans NetBean, ou alors ce ne sont pas les mêmes utilisées pour les applications mobiles.
Comme je n'en ai jamais développer je ne peux pas t'aider plus désolé.
il faut ajouter le /bin à la fin de la variable d'environnement $JAVA_HOME
Si tu as windows XP , ca doit etre la meme erreur que moi !
Si tu trouve la solution dis le moi !

Merci
Au fait veronique tu as quelle version du JDK ?
Moi j'ai la version 1.3.0 et je crois que le probleme vient de la ! je vais mettre a jour le JDK et voir si ca marche !
Je te tiens au courant !
Est ce que vous avez télécharger "la machine virtuelle java"?
Bonjour j'ai downloader un programme java et j'ai eu le probleme "Java.lang.noclassdeffounderror"
Dans le fichier que j'ai downloader il y avait des app.java et app.class
j'ai décompresser le fichier dans c:\monfichier\
ensuite dans la ligne de commande j'ai taper
c:\set classpath=c:\monfichier
ensuite
c:\java app
app est le nom du fichier sans le .java ou .class et le programme c'est exécuter
en passant pour configurer des variables d'environnement sous Windows XP il faut aller dans control panel->system->advanced->environnement variable
désoler pour les terme en anglais mon XP est anglais mais c'est probablement
Panneau de configuration->systeme->option avancer->variable d'environnement
de là vous pouver ajouter et/ou modifier des variables déja existante
Messages postés
1
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
7 avril 2008

bonsoir!svp j'ai un probleme au niveau de netbeans;un message d'erreurr cannot access.svp aidez moi
Messages postés
1
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
7 avril 2008

bonsoir;quand j'ouvre une appliction mobile(envoie de cv via bluetooth) sur netbeans il m'affiche des erreures "cannot access java.lang.que dois je faire ;
merci
Salut a ts !

Je suis sous vista depuis 2 jours et quand j'installe un jeu (fm2007) voila le message qui m'apparait :

java.lang.NoClassDefFoundError: run
Exeception in thread "main"

Quelqu'un aurait une soluce...

Merci d'avance !

SOLUTION
J'ai pas tous lu mais ici des proposition semble faire l'affaire...

POUR MA PART, J'AI SIMPLEMENT BOUGER LE .class LOSRQUE JE LANCE LA COMMANDE java

=> compiler sans message d'erreur = javac monprograme.java
=> EXECUTER sans message d'erreur = javac monprogram