NB.SI conditionnel

Résolu/Fermé
alexis - 12 févr. 2021 à 16:04
M-12
Messages postés
1201
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
29 juin 2022
- 12 févr. 2021 à 16:27
Bonjour,

je tente de faire une formule avec le NB.SI et le NB.SI.ENS

mais je trouve pas de solution j'ai 2 tableaux

l'un avec le nom de mes prestataires et l’autre avec l’occurrence de mes factures et je voudrais que si je met un symbole ou un mot du genre OK ca me compte tout les occurence rattaché à ce prestataires .

je vous met le tableau en lien en esperant avoir été clair

ps: les formule mis dans le premier tableaux se sont pas bonnes

https://we.tl/t-NUgkreBhhx


en vous remerciant d'avance


Configuration: Windows / Firefox 85.0

3 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 262
12 févr. 2021 à 16:20
Bonjour
en feuille Factures D4 à tirer sur la hauteur (attention aux $)
=NB.SI.ENS(Factures!$D$8:$D$204;B4;Factures!$I$8:$I$204;"OK")
crdlmnt
1
M-12
Messages postés
1201
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
29 juin 2022
263
12 févr. 2021 à 16:27
Bonjour,
Remplace tes formules en D4 et E4 par

en D4
=NB.SI(Factures!$D$8:$D$204;B4)

En E4
=NB.SI.ENS(Factures!D2:D197;B4;Factures!I2:I197;"=OK")
1
yclik
Messages postés
2893
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
29 juin 2022
1 323
12 févr. 2021 à 16:20
Bonjour
en D4 feuille "sociétés"

=SOMMEPROD((Factures!$D$8:$D$204=B4)*(Factures!$I$8:$I$204="OK"))

ou
=SOMMEPROD((Factures!$D$8:$D$204=B10)*(Factures!$I$8:$I$204="OK")*1)
0