Excel - formule de calcu SI / ALORS [Résolu]

Signaler
-
Messages postés
2349
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
4 mars 2021
-
Je veux qu'une cellule affiche un chiffre de 1 à 7 selon le texte renseigné dans une autre cellule de la ligne du tableau.
Exemple :
SI cellule1 = AA ALORS cellule2 = 1
OU SI cellule1 = BB ALORS cellule2 = 2
OU SI cellule1 = CC ALORS cellule2 = 3
etc jusqu'à OU SI cellule1 = GG ALORS cellule2 = 7
Est-ce possible de faire une série de plusieurs SI ALORS OU SI ALORS ?
Merci !

3 réponses

Messages postés
3085
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
3 mars 2021
426
Bonjour,

Un fichier EXCEL (test ou non), complété par des explications exhaustives et des exemples remplis à la main, mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question.

Crdmt
merci pour le conseil, je me garde le lien pour la prochaine fois :-)
Messages postés
9680
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
3 mars 2021
2 047
Bonjour

Un début à compléter (avant le "")
=SI(A2="AA";1;SI(A2="BB";2;SI(A2="CC";3;SI(A2="DD";4;SI(A2="EE";5;"")))))

Cdlmnt
Excellent ! merci beaucoup !!
Messages postés
2349
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
4 mars 2021
1 035
Bonsoir
si les lettres sont toujours doublées
=CODE(A2)-64