NB.SI.ENS Différent de

Résolu/Fermé
nicolas4107
Messages postés
3
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
7 juillet 2015
- 7 juil. 2015 à 11:56
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 7 juil. 2015 à 15:46
Bonjour,
J'ai un soucis avec la formule Excel NB.SI.ENS.
Je veux ce qui est différent de 20-12 donc j'inscrit la valeur suivante :
....;"<>20-12")
Hors Excel m'interprète cela comme tous ce qui est différent de 8. (20 - 12)
Quelqu'un aurait la solution ?
A voir également:

1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
Modifié par Vaucluse le 7/07/2015 à 12:18
Bonjour
si vous écrivez 20-12, rien d'étonnant à ce qu'Excel prenne ça pour un 8, il y a des tas de mathématiciens qui ont fait ça avant lui!
si vous voulez compter les valeurs différentes de 8 ou 20 dans un champ A1:A100

=NB.SI.ENS(A1:A100;"<>12";A1:A100;"<>20")
et si votre champ contient des cellule vides à ne pas compter:
=NB.SI.ENS(A1:A100;"<>12";A1:A100;"<>20";A1:A100;"<>")

Mais en final, si c'est un texte que vous voulez exclure:

=NB.SI(A1:A100;"<>"&20-12)

crdlmnt


Errare humanum est, perseverare diabolicum
6
nicolas4107
Messages postés
3
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
7 juillet 2015

7 juil. 2015 à 13:31
Bonjour Vaucluse et merci de votre réponse.
C'est bien un texte que je souhaite exclure.
Je viens d'essayer "<>"&20-12 mais Excel continu de considérer que c'est un 8 !
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
7 juil. 2015 à 14:00
Exact, j'ai du rater quelque chose dans mon essai.
Je n'ai jamais traité ça comme ça!!!??
mais curieusement, si cette fois je n'ai pas fait d'erreur, la formule,compte bien le nombre de 20-12 dans la liste avec:

NB.SI(A1:A10;"20-12") et ne les confond pas avec une valeur 8

alors on peut tenter:
=NBVAL(A1:A100)-NB.SI(A1:A100;"20-12")

ou alors plus simplement:
=SOMMEPROD((A1:A100<>"20-12")*1)

crdlmnt
1
nicolas4107
Messages postés
3
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
7 juillet 2015
> Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022

7 juil. 2015 à 15:37
Je viens d'utiliser la méthode suivante qui fonctionne, cela n'est pas à mon avis la meilleure solution, il doit y avoir plus simple mais cela a le mérite au moins de fonctionner !
=NBVAL(A1:A100)-NB.SI(A1:A100;"20-12")
Cela a résolu mon problème, merci beaucoup !
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256 > nicolas4107
Messages postés
3
Date d'inscription
mardi 7 juillet 2015
Statut
Membre
Dernière intervention
7 juillet 2015

7 juil. 2015 à 15:46
OK, je passe le sujet en résolu
.. mais pour moi SOMMEPROD fait plus "propre"
Bonne route
crdlmnt
0