J'ai un petit problème avec l'installation des extensions de twig

Signaler
Messages postés
64
Date d'inscription
mercredi 30 mai 2018
Statut
Membre
Dernière intervention
4 février 2020
-
 DarkChyper -
Bonjour, J'ai un petit problème avec l'installation des extensions de twig quand je lance la commande "composer require twig/extensions" j'ai le message d'erreur suivant je ne colle pas tout car c'est vraiment long!


C:\wamp64\www\Symfony\ProjetWebSymfony>composer req twig/extensions
Using version ^1.5 for twig/extensions
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Restricting packages listed in "symfony/symfony" to "5.0.*"
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don't install twig/extensions v1.5.4
- Conclusion: don't install twig/extensions v1.5.3
- Conclusion: don't install twig/extensions v1.5.2
- Conclusion: don't install twig/extensions v1.5.1
- Conclusion: remove doctrine/doctrine-bundle 2.0.7
- Conclusion: don't install doctrine/doctrine-bundle 2.0.7
- twig/twig v1.27.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.28.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.28.1 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.28.2 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.29.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.30.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.31.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.32.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.33.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.33.1 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v1.33.2 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v2.0.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v2.1.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v2.2.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v2.3.0 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v2.3.1 conflicts with doctrine/doctrine-bundle[2.0.7].
- twig/twig v2.3.2 conflicts with doctrine/doctrine-bundle[2.0.7].
- Conclusion: don't install symfony/http-kernel v5.0.3|install twig/twig v1.27.0|install twig/twig v1.28.0|install twig/twig v1.28.1|install twig/twig v1.28.2|install twi
g/twig v1.29.0|install twig/twig v1.30.0|install twig/twig v1.31.0|install twig/twig v1.32.0|install twig/twig v1.33.0|install twig/twig v1.33.1|install twig/twig v1.33.2|ins
tall twig/twig v2.0.0|install twig/twig v2.1.0|install twig/twig v2.2.0|install twig/twig v2.3.0|install twig/twig v2.3.1|install twig/twig v2.3.2
- Conclusion: remove symfony/http-kernel v5.0.3|install twig/twig v1.27.0|install twig/twig v1.28.0|install twig/twig v1.28.1|install twig/twig v1.28.2|install twig/twig
v1.29.0|install twig/twig v1.30.0|install twig/twig v1.31.0|install twig/twig v1.32.0|install twig/twig v1.33.0|install twig/twig v1.33.1|install twig/twig v1.33.2|install tw
ig/twig v2.0.0|install twig/twig v2.1.0|install twig/twig v2.2.0|install twig/twig v2.3.0|install twig/twig v2.3.1|install twig/twig v2.3.2
- twig/twig v1.34.0 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.34.1 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.34.2 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.34.3 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.34.4 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.35.0 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.35.1 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.35.2 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.35.3 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.35.4 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.36.0 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.37.0 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.37.1 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.38.0 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.38.1 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.38.2 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.38.3 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.38.4 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.39.0 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.39.1 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.40.0 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.40.1 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.41.0 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.42.0 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.42.1 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.42.2 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.42.3 conflicts with symfony/http-kernel[v5.0.3].
- twig/twig v1.42.4 conflicts with symfony/http-kernel[v5.0.3].
- Conclusion: don't install twig/twig v3.0.1|install twig/twig v1.27.0|install twig/twig v1.28.0|install twig/twig v1.28.1|install twig/twig v1.28.2|install twig/twig v1.
29.0|install twig/twig v1.30.0|install twig/twig v1.31.0|install twig/twig v1.32.0|install twig/twig v1.33.0|install twig/twig v1.33.1|install twig/twig v1.33.2|install twig/
twig v1.34.0|install twig/twig v1.34.1|install twig/twig v1.34.2|install twig/twig v1.34.3|install twig/twig v1.34.4|install twig/twig v1.35.0|install twig/twig v1.35.1|insta
ll twig/twig v1.35.2|install twig/twig v1.35.3|install twig/twig v1.35.4|install twig/twig v1.36.0|install twig/twig v1.37.0|install twig/twig v1.37.1|install twig/twig v1.38
.0|install twig/twig v1.38.1|install twig/twig v1.38.2|install twig/twig v1.38.3|install twig/twig v1.38.4|install twig/twig v1.39.0|install twig/twig v1.39.1|install twig/tw
ig v1.40.0|install twig/twig v1.40.1|install twig/twig v1.41.0|install twig/twig v1.42.0|install twig/twig v1.42.1|install twig/twig v1.42.2|install twig/twig v1.42.3|install
twig/twig v1.42.4|install twig/twig v2.0.0|install twig/twig v2.1.0|install twig/twig v2.2.0|install twig/twig v2.3.0|install twig/twig v2.3.1|install twig/twig v2.3.2
- Conclusion: don't install twig/extensions v1.5.4|remove twig/twig v3.0.1|install twig/twig v1.27.0|install twig/twig v1.28.0|install twig/twig v1.28.1|install twig/twig
v1.28.2|install twig/twig v1.29.0|install twig/twig v1.30.0|install twig/twig v1.31.0|install twig/twig v1.32.0|install twig/twig v1.33.0|install twig/twig v1.33.1|install t
wig/twig v1.33.2|install twig/twig v1.34.0|install twig/twig v1.34.1|install twig/twig v1.34.2|install twig/twig v1.34.3|install twig/twig v1.34.4|install twig/twig v1.35.0|i
nstall twig/twig v1.35.1|install twig/twig v1.35.2|install twig/twig v1.35.3|install twig/twig v1.35.4|install twig/twig v1.36.0|install twig/twig v1.37.0|install twig/twig v
1.37.1|install twig/twig v1.38.0|install twig/twig v1.38.1|install twig/twig v1.38.2|install twig/twig v1.38.3|install twig/twig v1.38.4|install twig/twig v1.39.0|install twi
g/twig v1.39.1|install twig/twig v1.40.0|install twig/twig v1.40.1|install twig/twig v1.41.0|install twig/twig v1.42.0|install twig/twig v1.42.1|install twig/twig v1.42.2|ins
tall twig/twig v1.42.3|install twig/twig v1.42.4|install twig/twig v2.0.0|install twig/twig v2.1.0|install twig/twig v2.2.0|install twig/twig v2.3.0|install twig/twig v2.3.1|
install twig/twig v2.3.2
- Conclusion: don't install twig/extensions v1.5.4|don't install twig/twig v3.0.1|install twig/twig v1.27.0|install twig/twig v1.28.0|install twig/twig v1.28.1|install tw
ig/twig v1.28.2|install twig/twig v1.29.0|install twig/twig v1.30.0|install twig/twig v1.31.0|install twig/twig v1.32.0|install twig/twig v1.33.0|install twig/twig v1.33.1|in
stall twig/twig v1.33.2|install twig/twig v1.34.0|install twig/twig v1.34.1|install twig/twig v1.34.2|install twig/twig v1.34.3|install twig/twig v1.34.4|install twig/twig v1
.35.0|install twig/twig v1.35.1|install twig/twig v1.35.2|install twig/twig v1.35.3|install twig/twig v1.35.4|install twig/twig v1.36.0|install twig/twig v1.37.0|install twig
/twig v1.37.1|install twig/twig v1.38.0|install twig/twig v1.38.1|install twig/twig v1.38.2|install twig/twig v1.38.3|install twig/twig v1.38.4|install twig/twig v1.39.0|inst
all twig/twig v1.39.1|install twig/twig v1.40.0|install twig/twig v1.40.1|install twig/twig v1.41.0|install twig/twig v1.42.0|install twig/twig v1.42.1|install twig/twig v1.4
2.2|install twig/twig v1.42.3|install twig/twig v1.42.4|install twig/twig v2.0.0|install twig/twig v2.1.0|install twig/twig v2.2.0|install twig/twig v2.3.0|install twig/twig
v2.3.1|install twig/twig v2.3.2

et tout à la fin j'ai cette erreur qui s'affiche !

Installation failed, reverting ./composer.json to its original content.




Configuration: Windows / Chrome 79.0.3945.130

5 réponses

Messages postés
2075
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
16 mars 2020
282
Bonjour,

Avec la V5 de Symfony, beaucoup d'extensions coincent car certains éléménts ont un conflit de version.

Utilises-tu Twig au sein de Symfony ou de manière autonome ?
Messages postés
64
Date d'inscription
mercredi 30 mai 2018
Statut
Membre
Dernière intervention
4 février 2020
1
j'utilise twig au sein de symfony je crois ! veux tu mon composer.json ?
Messages postés
2075
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
16 mars 2020
282
Il ne m'avancerai pas à grand chose.

Je pense que twig/extensions n'est pas compatible avec la dernière version de Twig utilisée par Symfo


Cordialement,
Messages postés
64
Date d'inscription
mercredi 30 mai 2018
Statut
Membre
Dernière intervention
4 février 2020
1
merci d'avance mais es ce que il vont corriger cette erreur ? et après si c'est le cas je fais un composer u et c bon ?
Messages postés
2075
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
16 mars 2020
282
Je ne sais pas si ils vont corriger la chose, il faudrait voir si le projet est encore maintenu (peut être que d'autres extensions font la même chose aussi)

Pour retirer on fait :
composer remove "twig/extensions"
Je viens d'avoir le même soucis avec symfony 4.4.

Ce que j'ai fais c'est ajouter manuellement "twig/extensions": "*" à mon fichier composer.json, puis j'ai fais un composer update.

Là il est descendu en version de twig pour trouver une version compatible de twig/extensions.