Arrondi 5 ou 9 Inférieur

Résolu/Fermé
ju - 26 déc. 2017 à 16:15
 ju - 29 déc. 2017 à 09:41
Bonjour,

je souhaiterai modifier une formule que j'ai trouvé ici même pour faire des arrondis à 5 ou 9 inférieurs

La formule trouvée :

=ARRONDI.AU.MULTIPLE(A2;5)-(MOD(ARRONDI.AU.MULTIPLE(A2;5)/10;1)=0)*1

Le résultat souhaité :

90€ = 89€
91€ = 89€
92€ = 89€
93€ = 89€
94€ = 89€
=====
96€ = 95€
97€ = 95€
98€ = 95€
99€ = 95€

Votre aide est la bienvenue, merci d'avance !

PS : si en plus de la formule, je peux avoir des explications sur cette dernière histoire que je ne vous embête pas la prochaine fois ... ;)

Cdt

3 réponses

yg_be
Messages postés
20053
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
19 août 2022
1 197
Modifié le 26 déc. 2017 à 16:47
bonjour,
je propose ceci:
=10*TRONQUE(A2/10)+SI(A2-10*TRONQUE(A2/10)>=5;5;-1)

ou
=10*TRUNC(A2/10)+IF(A2-10*TRUNC(A2/10)>=5;5;-1) 
0
Merci pour ta réponse !

j'ai testé, le résultat n'est pas concluant. Pour information j'ai oublié de préciser que les arrondis devront s'effectuer pour tout chiffres et pas uniquement les "9x" :)
0
yg_be
Messages postés
20053
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
19 août 2022
1 197 > ju
26 déc. 2017 à 17:46
quelle valeur ne te donne-t-elle pas le bon résultat? que donne la formule pour cette valeur?
0
Hello,

après nouveau test ce matin, il s'avère qu'hier on a eu un problème ICC (interface chaise clavier).
Avec mes excuses, ta première formule semble être exactement ce qu'il me faut.
Un grand merci à toi !
0
michel_m
Messages postés
16574
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
3 août 2022
3 278
26 déc. 2017 à 17:40
Bonjour Ju
1/ sans le symbole €
2/ tu n'as pas considéré le cas de 95 : je l'at mis dans le groupe>=5

=SI(MOD(A2;10)<5;A2-MOD(A2;10)-1;A$2-MOD(A$2;10)+5)
0
yg_be
Messages postés
20053
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
19 août 2022
1 197
26 déc. 2017 à 20:28
à condition que ce soit des nombres entiers.
0
Bonjour Michel,

merci de ta réponse, la journée d'hier ayant été intense, j'avais mal testé la formule de "yg_be" qui s'avère répondre à mon besoin.
Merci encore à tout les deux d'avoir pris le temps.
Agréable journée !

Cdt,
Ju
0
Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
1 754
27 déc. 2017 à 10:28
Bonjour Ju,

Ou encore :
=A2-MOD(A2;5)-ENT(MOD(A2+5;10)/5)
0
Hello Patrice !

Merci de ta réponse, celle de yg_be a répondu parfaitement à mes attentes, je testerai la tienne quand j'aurais un peu de temps pour comparer les comportements à titre de curiosité ^^
0