Arrondi 0.5 au nombre inférieur [Fermé]

Signaler
-
 Cédric0063 -
Bonjour,


La fonction ARRONDI arrondit un nombre contenant une fraction de la manière suivante : si la partie fractionnaire est égale à 0,5, le nombre est arrondi au nombre supérieur.

Pour le travail que j'ai à effectuer, je voudrais l'inverse : si la partie fractionnaire est égale à 0.5, le nombre est arrondi au nombre inférieur.

Si mon résultat est égal à 10.555 alors arrondir à 10.55

Merci d'avance pour vos réponses.

Cordialement.

4 réponses

Messages postés
2459
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
1 avril 2021
957
Re
À vérifier: =ARRONDI.SUP(A1-0,005;2)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2459
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
1 avril 2021
957
Bonjour,
Il y a aussi: =ARRONDI.INF(A1;2)
Malheureusement cela ne répond pas à ma question (voir mon commentaire précédent)
Merci quand même.
Messages postés
25948
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
5 864
Bonjour
Tontong a surement raison, toutefois pour bien se comprendre, si on reprend votre question:
" si la partie fractionnaire est égale à 0.5, le nombre est arrondi au nombre inférieur."
C'est quoi, dans ce cas le nombre infèrieur??
crdlmnt
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
560
Bonjour,

Essaie avec la fonction TRONQUE

Cordialement.
Bonjour et et merci d'avoir pris l'attention de lire mon sujet.
Cependant, si je tronque, lorsque ma valeur sera égale à 10.556, cela me donnera 10.55 alors que je voudrais à ce moment là un résultat à 10.56.
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
560
Peut-être

Avec valeur en A12
=SI(A12*100-ENT(A12*100)>0,5;ARRONDI(A12;2);ARRONDI.INF(A12;2))
Après vérification, votre méthode fonctionne. Mais je trouve que cela devient très compliqué dès que nous voulons défier les lois des mathématiques.

Merci en tout cas pour cette réponse claire.

Cordialement.