Afficher un ensemble de valeurs correspondantes à une autre

[Résolu/Fermé]
Signaler
Messages postés
11
Date d'inscription
mercredi 5 novembre 2014
Statut
Membre
Dernière intervention
14 avril 2016
-
Messages postés
17539
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 septembre 2021
-
Bonjour,

C'est un peu compliqué à expliquer...

J'ai une premier tableau ("Tableau 1" dans les images) dans lequel il y a une colonne "Code" et une colonne "Nom". Il peut y avoir un même couple Code/Nom Plusieurs fois dans le tableau


Dans mon second tableau ("tableau 2" dans les images j'ai une colonne "Code" et Une Colonne "Noms" (Au pluriel). Dans cette denrière colonne je souhaiterais, par une formule, afficher l'ensemble des noms (dans une seule cellule) qui ont une correspondance avec un code dans le premier tableau en face du même code dans ce second tableau. Les cellules que je souhaite obtenir sont en rouge dans l'image:



Voila j'espère avoir été assez limpide....

j'attends impatiemment vos idées

3 réponses

Messages postés
16513
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
20 septembre 2021
3 221
Bonjour,

je ne vois qu'une macro pour résoudre ton pb mais...

question: est ce normal d'avoir plusieurs fois le m^me code dans le tableau 2 (code 101) ?

pour être efficace (ne pas refaire en "excel" les images=
mettre un extrait du classeur sans données confidentielles en pièce jointe sur https://www.cjoint.com/
et coller le lien proposé dans le message de réponse
Dans l'attente, merci
Messages postés
11
Date d'inscription
mercredi 5 novembre 2014
Statut
Membre
Dernière intervention
14 avril 2016
1
Bonjour,

J'ai réussi à résoudre le problème en passant par un troisième tableau qui compte pour chaque nom et chaque code, combien de fois le couple [Nom/Code] apparait.

ensuite j'imbrique les =SI( pour afficher les noms a la suite si le nombre de couple [Nom/Code] est différent de 0

Plus clair avec le fichier. J'ai créer un Tableau 3 et la colonne en Vert donne le résultat souhaité.

https://www.cjoint.com/c/ECurmdr5hgW
Messages postés
17539
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 septembre 2021
4 732
Salut,

tu peux encore simplifier, en supprimant la colonne K et
en L3 =NB.SI.ENS($G$3:$G$17;$A3;$H$3:$H$17;L$2)
en M3 =NB.SI.ENS($G$3:$G$17;$A3;$H$3:$H$17;M$2)
en N3 =NB.SI.ENS($G$3:$G$17;$A3;$H$3:$H$17;N$2)
incrémente les 3 cellules vers le bas

en C3 tu as 6 parenthèses en trop et tu supprimes la première conditionnelle
=SI(L3=0;"";$L$2&" ")&SI(M3=0;"";$M$2&" ")&SI(N3=0;" ";$N$2&" ")


A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.