Calc : probleme de format de cellule avec RECHERCHEV [Résolu/Fermé]

Signaler
Messages postés
13
Date d'inscription
mardi 19 août 2014
Statut
Membre
Dernière intervention
1 septembre 2014
-
Messages postés
13
Date d'inscription
mardi 19 août 2014
Statut
Membre
Dernière intervention
1 septembre 2014
-
Bonjour,

A l'aide d'une recherche verticale à partir de 8 feuilles liés à des fichiers, j'ai réalisé un tableau récapitulatif pour cela j'ai utilisé la formule:
=RECHERCHEV(C2;mois.$A$19:$H$300;7;0)
où "C2" est l'occurrence recherchée, "mois" le nom (variable) de la feuille, A19:A300 la colonnes où est la liste des occurrences (ce sont des noms), 7 le numéro de la colonne d'où la valeur doit être extraite
Le problème est que si je conserve le format initial de l'occurrence (en Colonne C et dans la zone A19/A300) à savoir [non prénom matricule] cela ne fonctionne pas (#N/D), mais que si je retire, au deux endroits, le matricule, là la formule fonctionne correctement.
Le matricule de forme alfa numérique est entre parenthèse (aaaa1234)
A noter que la liste en Colonne C a été créée à partir d'un filtre spécial avec "sans doublon" et "copier le résultat vers" cochés (des fois que cela influe...)
J'ai comparé les noms (en C et en A) avec la commande "Exact" : calc m'indique "vrai"
Merci de m'aider ou de tenter de m'aider à résoudre ce problème


A voir également:

10 réponses

Messages postés
13
Date d'inscription
mardi 19 août 2014
Statut
Membre
Dernière intervention
1 septembre 2014
2
Parallèlement, la réponse m'a été donné sur le forum d'open office :
dans Outils >>> Options >>> OpenOffice Calc >>> Calculer
décocher autoriser les caractères génériques dans les formules.
^Par Phip
Ca marche !!
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
26076
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 juin 2021
5 963
Bonjour

pour vérifier la conformité de votre liste C, copier un code en A et coller le à sa place en C voyez si ça fonctionne.

sinon déposez un exemple de votre modèle sur
https://www.cjoint.com/
car sans ça, difficile de comprendre avec vos infos, car vous ne dites pas quel est le code complet cherché dans A.

à vous lire
Messages postés
2483
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
18 juin 2021
1 135
Bonjour
Sans classeur d'exemple difficile à suivre

Peut être en concaténant les champs Nom Prénom Matricule
Mettre ce champ concaténé en 1ere colonne sur les feuilles où s'effectue la recherche et en critère de recherche dans la formule

exemple :
si Nom en B2, Prénom en C2, matricule en D2
NPM en A2 avec A2=B2&" "&C2&" "&D2


attention aux homonymes
Messages postés
13
Date d'inscription
mardi 19 août 2014
Statut
Membre
Dernière intervention
1 septembre 2014
2
d'abord merci pour les réponses et effectivement il me semblait que j'était tous ... sauf clair....
@vaucluse : Déjà effectuer mais l'erreur persiste
@yclik nom prénom et matricule sont dans la même cellule...

Donc si je compare [nom prénom] avec [nom prénom] ça marche mais si je ne modifie pas les cellules et que je compare [nom prénom matricule] avec [nom prénom matricule] cela ne fonctionne pas....

Mais je m'attelle à la réalisation d'un fichier modèle ce sera plus simple à comprendre...
Encore merci
Messages postés
26076
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 juin 2021
5 963
Le modèle ne sera pas de trop,, il est effectivement difficile de comprendre pourquoi la formule fonctionne avec un texte partiel et pas avec un texte complet, sauf à en déduire que matricule et nom prénom ne sont pas dans la même cellule?
A +

Messages postés
13
Date d'inscription
mardi 19 août 2014
Statut
Membre
Dernière intervention
1 septembre 2014
2
bonjour
Voici les exemples
https://www.cjoint.com/?DHBi3cBH8Me
Messages postés
26076
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 juin 2021
5 963
Bonjour
à priori le lien renvoie sur le slide dépôt de fichier, mais pas sur votre modèle
A+
Messages postés
13
Date d'inscription
mardi 19 août 2014
Statut
Membre
Dernière intervention
1 septembre 2014
2
chez moi ça marche...
Le fichier s'appelle exemples et il est Zippé
je remet le lien au cas où...

https://www.cjoint.com/?DHBi3cBH8Me

A+
Messages postés
26076
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 juin 2021
5 963
Désolé, je ne peux pas y accèder
ci dessous ce que ci joint affiche
Par choix de son publicateur ou par opération de purge, ce document n'est plus hébergé par CJoint
Messages postés
13
Date d'inscription
mardi 19 août 2014
Statut
Membre
Dernière intervention
1 septembre 2014
2
Je ne sais pas d'où viens le problème de mon côté le fichier est toujours consultable.
Néanmoins je change de façon d'anticiper le problème, cf suite de la discussion, j'ai donc clôturé le sujet
Encore merci pour le temps passé
A+
Messages postés
2483
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
18 juin 2021
1 135
Bonjour
A priori les parenthèses perturbent la fonction RECHERCHEV

une proposition de solution est de supprimer les parenthèses dans la recherche avec la formule à placer en 1ère colonne de chaque feuille

=SUBSTITUE((SUBSTITUE(B2;"(";" "));")";"")

et la formule de recherche devient
en janvier 1ère ligne
=RECHERCHEV(A2;janvier.$A$19:$I$128;8;0)
Messages postés
13
Date d'inscription
mardi 19 août 2014
Statut
Membre
Dernière intervention
1 septembre 2014
2
Effectivement c'est bien la faute aux parenthèses...
et votre formule pour les supprimer marche
Seul bémol mes feuilles mensuelles sont liées à d'autres fichiers (et il faut qu'elle le reste)
Donc dés que j'actualise les liens les formules de substitution dans les feuilles mensuelles sont supprimées et cela ne marche plus...
Je vais changer de méthode et voir comment je peu construire ma liste différemment
Quitte à créer un autre sujet ....
En tous cas merci pour le temps passé
A+