RECHERCHEV additionne les plusieurs lignes du meme nom

Résolu/Fermé
pfl.bourde Messages postés 13 Date d'inscription mardi 12 septembre 2017 Statut Membre Dernière intervention 26 octobre 2017 - 26 oct. 2017 à 10:40
pfl.bourde Messages postés 13 Date d'inscription mardi 12 septembre 2017 Statut Membre Dernière intervention 26 octobre 2017 - 26 oct. 2017 à 11:04
Bonjour,

J'ai un fichier excel avec des numéros de dossiers en colonne A, les numéros de factures en colonne B et les montants des factures en colonne C.
Il peut y avoir plusieurs factures pour un même numéro de dossier, donc plusieurs lignes pour un même dossier. Exemple:

Dossier Facture Montant
121212 011065 500,00
121212 021065 500,00
121212 031065 500,00

Sur un autre fichier ou son répertoriés les numéros de dossiers, je souhaite effectuer une RECHERCHE V pour récupérer le montant total des factures par dossier.

PROBLÈME : lorsque je fais une RECHERCHEV par dossier, la formule ne prend en compte que la première ligne qui comporte ce numéro de dossier et n’additionne pas toutes les lignes.
RECHERCHEV(121212;A2:C4,3,FAUX) = 500,00 et pas 1500,00.

Quelle formule pourrait-on utiliser pour additionner le montant de toutes factures correspondant au numéro de dossier 121212 ?

Je vous remercie par avances pour vos réponses!

Cordialement.
A voir également:

1 réponse

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 394
26 oct. 2017 à 10:44
Bonjour

=SOMME.SI(champ des N°;N° de dossier; champ des montants)

soit selon votre exemple:

=SOMME.SI(A2:A4;121212;C2;C4)

ou si la référence est en Z1

=SOMME.SI(A2:A4;Z1;C2;C4)

crdlmnt
0
pfl.bourde Messages postés 13 Date d'inscription mardi 12 septembre 2017 Statut Membre Dernière intervention 26 octobre 2017
26 oct. 2017 à 11:04
Merci pour votre solution!

Simple, efficace, je n'y avais pas pensé.

Bonne journée!
0