Fontion SI et OU dans Open Office Calc [Résolu/Fermé]

Signaler
Messages postés
154
Date d'inscription
jeudi 3 juillet 2008
Statut
Membre
Dernière intervention
13 août 2013
-
Messages postés
7
Date d'inscription
mardi 28 mai 2013
Statut
Membre
Dernière intervention
26 octobre 2013
-
Bonjour,

Voilà je voulais créer une condition mais je n'y arrive pas.
Je voulais mettre si A4 est in férieur à 50 alors C4 est égale à 4 ou si 50<A4<70 C4= 5 sinon C4= 6

En clair si A4 = 30 C4 = 4
A4=2,5 C4 = 4
A4= 50,5 C4= 5
A4 = 1000000 C4 = 6

J'éspère que vous avez comprit
Merci d'avance.

7 réponses

Messages postés
7391
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
28 août 2020
3 047
salut
a priori
Mettre en C4 =SI(A4<50;4;SI(ET(A4>=50;A4<1000000);5;6))
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
7391
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
28 août 2020
3 047
oui désolé je suis allé un peu vite il faut utiliser aussi la fonction ET

=SI(B3<=15;1;SI(ET(15<B3;B3<=30);2;SI(ET(30<B3;B3<=45);3;SI(ET(B3>45;B3<=60);4;""))))
Messages postés
154
Date d'inscription
jeudi 3 juillet 2008
Statut
Membre
Dernière intervention
13 août 2013
7
Merci beaucoup
Messages postés
7
Date d'inscription
mardi 28 mai 2013
Statut
Membre
Dernière intervention
26 octobre 2013
1
Bonsoir,
Et si je veux rajouter une condition supplémentaire comme suit :

B3 <=15 C4 = 1
B3 <=30 C4= 2
B3 <=45 C4 = 3
B3 <=60 C4 = 4

J'ai bien essayé de compléter la formule comme ci-après mais en vain.

=SI(B3<=15;1;SI(ET(B3<=30;B3<=45;B3<=60);2;3;4))

Merci de votre concours.
Messages postés
7391
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
28 août 2020
3 047
bonjour
là tu es obligé d'encadrer tes variables
=SI(B3<=15;1;SI(15<B3<=30;2;SI(30<B3<=45;3;SI(45<B3<=60;4;""))))


attention au nombre de ) à la fin
le "" c'est pour dire que la cellule reste vide si B3 et >60 car tu n'as rien indiquer dans ce cas
Messages postés
7
Date d'inscription
mardi 28 mai 2013
Statut
Membre
Dernière intervention
26 octobre 2013
1
Merci beaucoup.
Il n'y a pas de possibilité au dessus de 60.

Edit : Je viens d'appliquer la formule mais elle ne fonctionne pas. Les valeurs au dessus de 30 ne sont pas prises en compte. La valeur reste à 2.
Messages postés
7
Date d'inscription
mardi 28 mai 2013
Statut
Membre
Dernière intervention
26 octobre 2013
1
Formidable !!!! Merci beaucoup.

Est ce qu'une demande de ma part plus compliquée encore peut être envisagée ou pas ?

Cdlt.
Messages postés
7
Date d'inscription
mardi 28 mai 2013
Statut
Membre
Dernière intervention
26 octobre 2013
1
Je reviens sur mon post juste pour dire que ce n'est quand même pas simple...
Messages postés
7391
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
28 août 2020
3 047
dis toujours
de toutes façons il y en a des beaucoup plus costauds que moi sur excel qui te répondront certainement
vise à bien expliquer ton pb voire à mettre un fichier exemple anonymiser sur cjoint.com
Messages postés
7
Date d'inscription
mardi 28 mai 2013
Statut
Membre
Dernière intervention
26 octobre 2013
1
Voilà mon problème !
Il est dans ce fichier :
http://alyann3.free.fr/Open_Office/Essai_Formules.ods

Comment faire pour que la feuille de calcul récupère les données (ligne) du tableau du bas en choisissant les données les plus proches de celles que je mentionne dans les cases vertes en les replaçant dans les cases rouges (facteur1, facteur2, etc..).
Voilà.
Si quelqu'un pouvait me donner un coup de main là-dessus, je l'en remercie.
Alyann3.
Messages postés
7391
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
28 août 2020
3 047
trop complexe pour moi
attends qq'un d'autre
autre solution poser ta question sur le forum dédié à OOo

https://forum.openoffice.org/fr/forum/viewforum.php?f=4&sid=c48d3244321fcac626c4392dec97ef1c
Messages postés
7
Date d'inscription
mardi 28 mai 2013
Statut
Membre
Dernière intervention
26 octobre 2013
1
Ton aide m'a été très précieuse.
Je vais de ce pas poser ma question là-bas.
Merci pour tout.