[PHP] config smtp du php ini pour envoi mail [Résolu/Fermé]

Signaler
Messages postés
131
Date d'inscription
jeudi 3 mai 2007
Statut
Membre
Dernière intervention
1 novembre 2008
-
 kamal -
bonjour tout le monde , j'ai un petit souci avec mes formulaires contact a chaque fois que j'entre les info et quand je clique envoyer il m'affiche ce message :
Warning: mail() [function.mail]: Failed to connect to mailserver at "smtp.xxxxxx.xxx" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set()


quelqu'un peut il me renseigner merci

24 réponses

Messages postés
131
Date d'inscription
jeudi 3 mai 2007
Statut
Membre
Dernière intervention
1 novembre 2008
36
j'ai pas bien compris ce que tu viens de me dire merci d'avane pour tes conseilles
9
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

si tu es sous wampserver :
configure ton fichier php.ini avec
SMTP = 127.0.0.1
smtp_port = 25
voilà, en espérant t'avoir aidé
comment je peux faire cette configuration ??
Messages postés
131
Date d'inscription
jeudi 3 mai 2007
Statut
Membre
Dernière intervention
1 novembre 2008
36
moi comme solution j'ai adopté local smtp relay server et ça marche bien je passe pas par mon fournisseur d'accès
9
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

comment tu l'as fait
salut,

alors si on configure smtp =localhost dans le fichier php.ini, comment alors on verifie l'envoi du fonction mail dans ma page contact??????

et dans mon page toujours il apparait ce message d'erreur:

Warning: mail(): Failed to connect to mailserver at "smtp.********.***" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in c:\program files\easyphp\..........

quelqu'un peut t il m'indique se trouve ou l'erreur ,es ce que le probleme vient du port smtp????????


merci
Tu es le propriétaire de ce serveur, donc si tu l'héberge chez toi, tu devrais savoir quelles sont les services que tu as installé.

biensure il existe des commande pour le savoir :.) heureusement.
# ps ax

et dans la liste tu obtiens une ligne qui ressemble un peu a ça:

12618 ?? Is 4:00.87 sendmail: accepting connections (sendmail)

et dans /etc/inetd.conf la ligne suivante doit etre décommenté:

pop3 stream tcp nowait root /usr/sbin/popa3d popa3d


vérifier si le serveur répond:

# telnet localhost smtp

essaie aussi cette commande, ca va te dire comment est configuré
ton sendmail:

sendmail -d0 < /dev/null


Si ta besoin de savoir comment faire des serveur chez toi tu peux te référer a ce site web:

http://www.sysinfos.com
Messages postés
8
Date d'inscription
vendredi 9 novembre 2007
Statut
Membre
Dernière intervention
30 novembre 2007
5
moi j'ai le meme probleme, je n'arrive pas a envoyer de mail, mon php.ini :
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = bunel_julien@yahoo.fr

et mon erreur est :

Warning: mail() [function.mail]: SMTP server response: 550 Delivery is not allowed to this address. in C:\public\iPhone\public\index.php on line 166

merci d'avance
; For Win32 only.
SMTP = localhost


SMTP = smtp.orange.fr

Si tu es chez orange sinon adapter. Je crois que chez Free il y a des problèmes avec cette fonction. A vérifier..
J'ai fait ça en cours dernièrement et ça a marché.
Messages postés
2557
Date d'inscription
samedi 21 juillet 2007
Statut
Membre
Dernière intervention
30 mai 2015
350
bonsoir il faut simplement mettre ça dans le bon php.ini

SMTP =smtp.orange.fr (evidemment si tu est chez orange, chez free ce sera smtp.free.fr etc..)
le port reste le 25 et tu devrais plus avoir de probleme

Pour verifier si c'est bien pris en compte place à la racine de ton site un fichier info.php et dedans tu met seulement ce code :
<?PHP
phpinfo();
?>

ensuite tu tape dans ton navigateur
www.url_de_ton_site/info.php

et tu aura tous les rensignements concernant ta config, notamment dans la partie mail
et bien adresse public cest ladresse attribué par ton fournisseur daccès internet et privé cest ladresse attribué par un routeur.

remplace smtp.xxxxxx.xxx soit par le ip de ton serveur smtp privé ou par celui de ton fournisseur
salut ,
mais aussi j'ai un probleme au niveau envoie du formulaire , pourtant j'ai bien configuré php.ini , j'ai bien verifié mon code mais ca marche pas comment faire pour que ca fonctionne
merci
Messages postés
42
Date d'inscription
samedi 26 janvier 2008
Statut
Membre
Dernière intervention
25 août 2011
11
toujours rien ?
Messages postés
131
Date d'inscription
jeudi 3 mai 2007
Statut
Membre
Dernière intervention
1 novembre 2008
36
salut tout d'abors merci de ta reponse , en faite je travail sur un serveur dedié donc je suis mon propre hebergeur , j'ai demandé au responsable qui a acheté ce serveur de me communiquer l'adresse smtp mais malheureusement il me dit qu'il ne l'a pas docn du cou je suis un peu bloqué sinon y'a t'il un autre moyen de contourné ça ? ou y'a t'il un moyen de connaitre le smtp de son serveur via des commande dos? merci
Messages postés
131
Date d'inscription
jeudi 3 mai 2007
Statut
Membre
Dernière intervention
1 novembre 2008
36
salut Bsdishers merci pour ta reponse j'ai retrouvé l'adresse smtp de mon serveur alors quand je je renseigne mon php.ini a l'execution de l'envoi du formulaire j'ai un message qui me dit
Mail() [function.mail]: SMTP server response: 452 4.3.1 Out of memory in C:\Projet\www\Site1\envoi.php on line 49
echo "erreur";


donc je pense que y'a un pb là
Salut,

Pour moi j'utilise la fonction mail() en local, j'ai pas de FAI

Dois je installer un serveur SMTP pour tester cette fonction en localhost.
Est ce que Easy php que j'utilise ne me fournit pas un serveur SMTP.
Comment configurer ce serveur dans les deux cas au niveau du fichier php.ini?
est ce que le serveur SMTP me permet de creer des comptes?
Puis je consulter(voir) le mail que j'ai envoyé(ya t'il une interface graphique le permettant)
??????????????????????
Bonjour

Il faut bien mettre un code d'accès (mot de passe) quelque part pour qu'Orange envoie tes messages. Tu le fais où ?
SMTP = smtp.ton_fournisseur_D_acces_internet.com

voila c tout si tu possedes pas de serveur courriel suffit d'utiliser celui de ton fournisseur internet

pour le reste si cela ne fonctionne pas, faudrait vérifier au niveau du code php que tu utilises, le probleme
vient p-t de la.
Messages postés
42
Date d'inscription
samedi 26 janvier 2008
Statut
Membre
Dernière intervention
25 août 2011
11
bonjour a tous,
bon je crois que je suis tombé au bon endrois pour posé ma question alors j'me lance

je vous explique,
j'avais déjà bien galéré pour pouvoir changer mon port qui créai des conflits avec le pare-feu... un classique quoi.
Au final j'utilise directement une adresse chiffrée: genre http://147.0.0.5:154

A présent je souhaite envoyé un mail en LOCAL mais je n'y arrive pas j'ai la même erreur que neofuturoxx à ces débuts et sur mon php.in j'ai ça:
[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

j'ai essayé tout le combinaisons possible, icompris les plus farfelues. tout ce qui change c'est les noms (dans l'erreur) et quand je met :
smtp_port = 154 (le port que j'utilise)

il charge la page a l'infini sans rien faire...

que dois-je faire??? dites moi... silvouplé ;)
Messages postés
42
Date d'inscription
samedi 26 janvier 2008
Statut
Membre
Dernière intervention
25 août 2011
11
Merci beaucoup, je vai essayer en ligne et je te dit quoi....
Pour infos le site en question est hebergé par OVH


mais si tu pouvais me dire comment faire pour pouvoir deja tester mon script d'envoi de mail en local
je t'en serai reconnaissant

mon port (pour les tests) est 154. (soit xxx.xx.xx.x:154)
je fait quoi dans php.ini??


merci encore
Messages postés
2557
Date d'inscription
samedi 21 juillet 2007
Statut
Membre
Dernière intervention
30 mai 2015
350
dans le php.ini tu met seulement cette ligne

SMTP =smtp.ton fai

pour avoir les smtp regarde ici
http://www.commentcamarche.net/faq/sujet 893 adresses des serveurs pop et smtp des principaux fai
et ca va marcher en local

si ton port est le 154 change le egalement dans le php.ini.
Mais je vois pas l'interet de changer le port ???

Ensuite il faut que l'adresse a laquelle tu envoie le mail soit egalement configurée avec le port 154
@+
comment savoir le fai de mon propre pc
Messages postés
42
Date d'inscription
samedi 26 janvier 2008
Statut
Membre
Dernière intervention
25 août 2011
11
salut Lewis34,
voila je t'explique, j'utilise une fonction mail pour envoyé un mail.
en local je travaille avec une adresse comme ça: http://127.0.0.1:154/

j'ai donc dans mon fichier httpd.conf ceci:
Listen 127.0.0.1:154

pour envoyer un mail (je suis sur gmail) j'ai été voir sur ton lien et j'ai mis ça dans le fichier php.ini:
[mail function]
; For Win32 only.
SMTP = smtp.gmail.com
smtp_port = 25
...
sendmail_from = mon_adresse@gmail.com

Maintenant quand j'execute le script de mail j'ai cette erreur:
Warning: mail() [function.mail]: SMTP server response: 530 5.7.0 Must issue a STARTTLS command first. d4sm1660718fga.9

je pense que ça doit avoir un rapport avec le port. mais si je change en 154 (smtp_port = 25), j'ai cette erreur:
Warning: mail() [function.mail]: Failed to connect to mailserver at "smtp.gmail.com" port 154, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set()

A part ça je n'ai pas bien compris ta dernière phrase, je dois aller sur mon compte mon_adresse@gmail.com et changer le port en 154?? où ça?? j'ai pas trouvé...

Tout ce que je peux dire c'est que le protocole POP est déjà activé.

voila j'espère avoir été assez complet. Et je te remercie encore pour ton intérêt à mon problème sur lequel je suis totalement bloqué.

merci donc... ;)
Messages postés
2557
Date d'inscription
samedi 21 juillet 2007
Statut
Membre
Dernière intervention
30 mai 2015
350
bonjour le port 154 n'a rien a voir avec le smtp, c'est 2 choses différentes tu envoi simplement tes requetes http sur le port 154 au lieu du 80

dans cette ligne
SMTP = smtp.gmail.com

remplace gmail.com par ton fai et ca devrais marcher
Messages postés
42
Date d'inscription
samedi 26 janvier 2008
Statut
Membre
Dernière intervention
25 août 2011
11 >
Messages postés
2557
Date d'inscription
samedi 21 juillet 2007
Statut
Membre
Dernière intervention
30 mai 2015

marci Lewis34,
j'ai en effet changé:

SMTP = smtp.gmail.com

et remplacer par celui de mon FAI (t2 belgique) ce qui donne:

SMTP = out.tele2allin.be
le port reste inchangé: 25

ET ça marche... un grand merci à toi.

---------------------------------------------------------------------------

pour Pierre1098, je ne vois pas trop ton probleme
essaye d'ajouter ça à ton $header:

$header .= "X-Mailer: PHP/" . phpversion() . "\n" ;

sinon je sais pas... bonne chance
Messages postés
2557
Date d'inscription
samedi 21 juillet 2007
Statut
Membre
Dernière intervention
30 mai 2015
350 >
Messages postés
42
Date d'inscription
samedi 26 janvier 2008
Statut
Membre
Dernière intervention
25 août 2011

de rien c'est avec plaisr ;-)
salut à tou
j'ai tou essai et tjs j'ai le m pb

message d'erreur :
" Warning: mail() [function.mail]: Failed to connect to mailserver at "smtp.gmail.com" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\Program Files\EasyPHP5.3.0\www\testmail.php on line 7
Le message n'a pu être envoyé "
quelqu'un peut m'aide
Messages postés
80
Date d'inscription
vendredi 5 juin 2009
Statut
Membre
Dernière intervention
2 février 2012
2
Bonjour donc moi j'ai le meme probleme que tou le monde j'en suis a ce point :
Dans php.ini :

[mail function]
; For Win32 only.
SMTP = smtp.orange.fr
smtp_port = 25

Mon code php :
<?php
$headers ='From: "Pierre"<pierre1098@hotmail.fr>'."\n";
$headers .='Reply-To: pierre1098@hotmail.fr'."\n";
$headers .='Content-Type: text/plain; charset="iso-8859-1"'."\n";
$headers .='Content-Transfer-Encoding: 8bit';

if(mail('pierrejolivet63@gmail.com', 'test', 'Message de test', $headers))
{
echo 'Le message a bien été envoyé';
}
else
{
echo 'Le message n\'a pu être envoyé';
}
?>

et mon message d'erreur :
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\Program Files\EasyPHP 3.0\www\stageeasy\mail.php on line 7
Le message n'a pu être envoyé


Si quelqu'un peut m'aider merci
il ya deus fichiers php.ini a modifie
Voila, je suis chez télé2 et voila ce que ca met :

Warning: mail() [function.mail]: Failed to connect to mailserver at "smtp.tele2.com" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\Program Files\EasyPHP 2.0b1\www\loji-web\admin\admin_newsletter.php on line 25


la même erreur que tout le monde, comment la résoudre ?

j'ai pas trouvé :s

et que dois je mettre précisement dans $headers ? quelle est l'adresse de l'expéditeur vu qu'on est en local ? :s

$headers = 'From: ladressedelexpediteur' . "\r\n" .
'Reply-To: ladressedudestinataire' . "\r\n" .
'X-Mailer: PHP/' . phpversion();