Phpmyadmin

[Fermé]
Signaler
Messages postés
102
Date d'inscription
mardi 22 janvier 2013
Statut
Membre
Dernière intervention
23 mars 2017
-
 Axton -
Bonjour,

J'ai installer dernièrement Phpmyadmin et cacti sur une distribution linux, debian. Mon problème est le suivant sur cacti je n'arrive pas à me loguer il me refuse ma connexion donc c'est pour cela que j'ai pris phpmyadmin et j'ai été voir le mot de passe cacti qui était le même que je tapais mais rien à y faire il ne veut pas me connecter alors est ce que par hasard il ne faudrait il pas que le snmp fonctionne pour pouvoir me connecter??? Au début j'ai pensé que c'était ma base de donné Mysql mais non ça ne vient pas d'elle enfin je crois. Mon autre petit souci est que je n'arrive pas à désinstaller mysql, par contre cacti c'est facile ça fonctionne du premier coup !!!!!

J'ai déjà poster ici des tuto pour savoir pourquoi mon snmp ne veut pas fonctionné.
J'ai besoin d'aide toutes les réponses même les plus insensé seront les bienvenus.

Cordialement,

Axton

6 réponses

Messages postés
1231
Date d'inscription
mardi 7 juin 2011
Statut
Membre
Dernière intervention
24 mai 2015
342
Bonjour,

phpmyadmin est il installé sur la même machine que mysql ? Par défaut, mysql est configuré (sous debian) pour n'accepter que les connexions locales...

Si c'est le cas et que mysql est configuré pour accepter les connexions venant de l'extérieur, vérifie que tu n'as pas un firewall qui rejette les connexions extérieures sur le port d'écoute de mysql...

Si les deux sont sur la même machine, ça pourrait être un paramètre de phpmyadmin... je ne l'utilise pas mais avec un peu de chances les fichiers de config' seront dans /etc/phpmyadmin/

Pour des tests, essaye de te connecter en ssh au serveur puis via ssh à mysql.
Si ça ne marche pas, le problème vient soit de mysql soit de ton login...

Si ça marche essaye de te connecter à mysql à distance :
mysql -uLogin -p -h serveur NomDeLaBase

Si ça ne marche pas, c'est que quelque chose empêche l'accès à mysql par le réseau.

Si ça marche, le problème vient des logiciels que tu utilises pour t'y connecter...

... enfin, je crois...

bonne chance,
Messages postés
102
Date d'inscription
mardi 22 janvier 2013
Statut
Membre
Dernière intervention
23 mars 2017
14
Bonjour,

Merci pour ta réponse je n'ai pas de firewall il est désactiver oui les fichier de conf sont dans ce chemin /etc/phpmyadmin via le ssh cela fonctionne ah oui en faites mon server debian est une virtuel et phpmyadmin et mysql sont sur la debian.

Désoler de te dire cela mais ça change rien ?????? J'aurai pas tout compris ????

Cordialement,

Axton
Messages postés
1231
Date d'inscription
mardi 7 juin 2011
Statut
Membre
Dernière intervention
24 mai 2015
342
Le but du jeu des tests est d'identifier à quel niveau le problème se pose... effectivement ils ne changeront rien à la configuration ; mais au moins tu sauras un peu mieux de quel coté chercher.

Et si quelqu'un nous lit il aura aussi plus de chances de pouvoir t'aider.

Messages postés
102
Date d'inscription
mardi 22 janvier 2013
Statut
Membre
Dernière intervention
23 mars 2017
14
RE

Ok et bien comme ça c'est clair merci !!!!

Cordialement,

Axton
Messages postés
1231
Date d'inscription
mardi 7 juin 2011
Statut
Membre
Dernière intervention
24 mai 2015
342
Bonjour,

Vérifie la configuration de phpmyadmin... je pense que par défaut il doit être configuré pour que tu ne puisses t'en servir que depuis la machine hôte. (Et donc depuis «localhost» «127.0.0.1» ou quelque chose dans ce goût là).

Il doit s'agir d'une ligne à modifier ou à commenter dans un des fichiers de configuration.

Bonne chance,
Bonjour,

Je ne pense pas que tu as compris mon problème =). J'arrive a me connecter sur phpadmin de n'importe ou sur le réseau via une interface web et avec mon ip server, le truc c'est pourquoi ce qui est marqué dans phpadmin ne correspond en rien au mot de passe et utilisateur. J'ai déjà essayer de me connecter en local sur phpadmin ça marche mais pas pour cacti et même en local, j'ai quand même regarder relu et relu les fichiers de conf mais rien enfin je crois à dé-commenter.

Cordialement,

Axton