Recherchev sur open office et erreur 502

[Résolu/Fermé]
Signaler
Messages postés
3
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
14 novembre 2011
-
Messages postés
54531
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 septembre 2021
-
Bonjour,
Celà fait des heures que je cherche comment faire une recherchev avec plusieurs feuille, un véritable calvaire pour moi qui suis assez nul sur excel et dû fait est que le prof s'est dépécher sur ça je m'éfforce enfin à chercher de l'aide même si j'aurai voulu me débrouiller mais là ça devient impossible.
C'est simple, en fait j'ai surtout un problème avec le critère de recherche.
Par exemple, j'ai une feuille facture et une feuille catalogue, je veux prendre de la feuille catalogue sa désignation à partir du code article, ce qui donne ça dans la feuille catalogue :

Code article Désignation
A4 = 1 B4 = Alimentation

Ici le tableau catalogue s'étend de A4 à C17 mais je souhaite pour le moment n'avoir que la désignation.
La difficulté ici est pour moi A4, car il suffit juste de recopier 1 (je pense ou c'est peut être là que j'ai faux) en A14 de le feuille facture.
Ensuite pour la feuille facture ça donne :

Code article désignation
A14 = 1 (recopié sans formule) B14 (la formule que j'ai tapé) = RECHERCHEV(A14;catalogue.A4:B17;14;FAUX) (ce qui donne erreur 502)

J'ai le même problème avec les clients dont le critère de recherche est le nom.
Comment faire ? Si j'ai faux, essayez d'expliquer clairement comment faire pour que A14 soit considéré comme un nombre comme A4 de catalogue afin que ma formule fonctionne. (pour moi même quand on m'explique excel j'ai dû mal)

2 réponses

Messages postés
3
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
14 novembre 2011

Bonjour,
Merci de votre aide, ma seule erreur était en réalité sur le 14 qui était 2 (encore ça je sais pas comment on sait que c'est 1 ou 2 m'enfin), sinon j'ai fais:
RECHERCHEV(A14;catalogue.A4:B17;2;0) et ça marche parfaitement alors que hier et samedi j'étais persuadée d'avoir fait excatement la même opération, je finis par croire à un bug de open office à ce moment là. Enfin pour ce qui est du '!' au lieu du '.' 'c'est la version de open office qui veut ça d'où c'est bon.
Messages postés
54531
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 septembre 2021
16 463
Ah ! Je m'excuse pour le "!" : c'est vrai que je raisonne toujours en excel ...

Pour le 1 et le 2, c'est simple : ce chiffre indique quelle colonne de la plage contient l'information à afficher
La colonne A contient le code, et la colonne B la désignation de l'article
B est la colonne N° 2 de la plage de recherche A4:B17
Si la plage était R4:S17 il s'agirait toujours de la colonne N° 2 de la plage et la formule serait RECHERCHEV(A14;catalogue.R4:S17;2;0)
Messages postés
12
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
19 mars 2014

Bonjour,

Avec RECHERCHEV, la fonction copie la valeur sur la meme ligne mais plusieur colonnes plus loin. Donc si ta table catalogue va de la colonne A a C, alors ton troisieme element de ta formule ne peut pas etre 14, seulement 1 ou 2.

RECHERCHEV(A14;catalogue.A4:B17;2;Faux)

Cela veut dire recherche la valeur en A14 dans la feuille catalogue, dans la colonne A entre les cellules A4 a A17 et copie moi la valeur sur la meme ligne qui se trouve dans la colonne B.
Messages postés
54531
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 septembre 2021
16 463
Excellente explication.

Petite erreur à corriger, un point d'exclamation :
catalogue!A4:B17 au lieu de catalogue.A4:B17

Et il faut espérer que les deux feuilles appartiennent bien au même dossier (fichier) ?

P.S. : On peut aussi définir le nom "cat" pour la plage A4:B17 de la feuille catalogue, ce qui permet d'écrire la formule =RECHERCHEV(A14;cat;2;FAUX)