[Debian] xorg & NVidia : écrasement d'un lien [Résolu/Fermé]

Signaler
Messages postés
789
Date d'inscription
samedi 26 février 2005
Statut
Contributeur
Dernière intervention
19 juillet 2009
-
Messages postés
29800
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
6 mai 2021
-
Bonjour a tous,

j'ai un petit souci avec le paquet debian xserver-xorg-core qui contient en particulier libglx.so . Or j'utilise en parallèle les drivers Nvidia obtenus sur le site de Nvidia.

en gros, l'installation du driver nvidia va créer un lien libglx.so qui va pointer vers la librairie libglx.so.0.XXXX qui vient du driver de Nvidia.

puis toutes les mises a jour de xserver-xorg-core écrasent ce lien en le remplacant par une librairie contenue dans le paquet .deb .

comment faire pour empecher ces remplacements intempestifs??

Phiphi

7 réponses

Messages postés
29800
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
6 mai 2021
7 087
A priori tu as des paquets debian tout prêts pour installer les drivers nvidia directement avec aptitude ou un de ses confrères. Je n'ai plus le mirroir en tête mais à mon avis c'est quand même le mieux, le plus propre, et le plus simple...

En particulier tu auras les paquets nvidia-glx, nvidia-kernel-taversiondekernel à installer.

Bonne chance
Messages postés
789
Date d'inscription
samedi 26 février 2005
Statut
Contributeur
Dernière intervention
19 juillet 2009
291
Salut,

merci pour ta réponse, et effectivement, j'ai utilisé nvidia-glx et nvidia-kernel (sauf que pour le dernier, j'ai du le construire, etant donné que j'utilise un noyau sorti de kernel.org....)

Phiphi
Messages postés
29800
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
6 mai 2021
7 087
C'est quoi ce xserver-xorg-core ? Je l'ai même pas dans la liste de mes package ? A priori tu as juste à mettre xserver-xorg, non ?

Bonne chance
Messages postés
789
Date d'inscription
samedi 26 février 2005
Statut
Contributeur
Dernière intervention
19 juillet 2009
291
Re,

en fait, le paquet xserver-xorg dépend de xserver-xorg-core
(mais je suspecte la version de xorg 7.0 de necessiter xserver-xorg-core, et pas la 6.9 ...)
remarque bien, ca me le faisait avant aussi, avec la 6.9, mais sans doute a cause du paquet xserver-xorg...

Phiphi
Messages postés
2041
Date d'inscription
dimanche 22 août 2004
Statut
Contributeur
Dernière intervention
13 novembre 2016
135
Salut vous deux,

effectivement, avec la debian sid, il doit y avoir un bug au niveau de la mise à jours du xserver-xorg vers la version 7 (7.0.12 exactement). C'est elle qui impose plein de paquet xserver-xorg-video-qqch., et veut virer un lien logique de trop.

vu qu'il voulais pas enlever un répertoire à cause de ce lien, l'ai viré à la mains... mal m'en a pris car me suis retrouvé sans interface graphique du tout :( Vu que j'avais d'autres choses à corriger, me suis refait tout l'installation, et là tout va pour le mieux.

bon, je sais, ça fait pas avancer le schmilblik, mais bon. donnera peut-être des idées à d'autres.

Renisaac
Messages postés
789
Date d'inscription
samedi 26 février 2005
Statut
Contributeur
Dernière intervention
19 juillet 2009
291
re!

non, il n'y a pas de bug de ce genre pour la mise a jour ;-)
en réalité, la version 7.0 de xorg, c'est grosso modo la meme que la 6.9, mais modularisée! (d'ou la kyrielle de paquets qui arrivent d'un coup)

voili, voilou, vivement xgl ;-)

Phiphi
Messages postés
29800
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
6 mai 2021
7 087
C'est vrai que xgl pour le peu que j'en ai vu ça va déchirer. Et en plus en hiver on aura même plus besoin du radiateur, la carte graphique s'en chargera :p