[Excel] NB.SI sur plusieurs plages [Fermé]

Signaler
-
 toto -
Bonsoir,

J'aurais besoin de chercher le nombre de fois qu'une certaine valeur apparaît, mais sur plusieurs plages.

Par exemple, chercher "pommes" dans les colonnes A1:A7 et C1:C7.


Je pourrais faire =NB.SI(A1:A7; "pommes") + NB.SI(C1:C7; "pommes") , mais dans mon cas j'ai plusieurs dizaines de colones sur 9 pages, et ça me fait une formule énorme et illisible...

J'ai essayé de sélectionner les différents plages, mais ça me donne : =NB.SI(A1:A7;C1:C7;"pommes") , ce qui ne fonctionne pas, même avec des parenthèses.


Avez-vous une idée de comment faire ?

4 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 355
bonjour

Tu peux essayer avec une formule matricielle mais tu as à peu près le même type de formule
=SOMME((A1:A7="pommes")*1;(C1:C7="pommes")*1;(F1:F7="pommes")*1)
à valider par "ctrl + maj + entrée" simultanément

Par contre, je ne connais pas ton classeur mais tu pourrais aussi faire le comptage même sur les colonnes non concernées :
=SOMME((A1:F7="pommes")*1)
ou
=SOMME((A1:IV5000="pommes")*1)
à valider par "ctrl + maj + entrée" simultanément

Bien sûr si au lieu des pommes c'est des 1 ou des zéros ...
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

En fait c'est pour faire les statistiques d'une équipe :

Une pages par match, une colonne buts et une colonne assists où je mets les noms, puis je compte par exemple combien de fois est cité Jean.

Le problème est que je ne peux pas englober plusieurs colonnes, car sinon il va chercher aussi dans les assists. Le problème est qu'il y a plusieurs pages et ça me fait une formule énorme avec une SOMME ou une addition de NB.SI
Tu sélectionne des deux champs, clic droit, définir un nom. puis tu utilise ce nom dans les formules
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 355
bonjour

Qu'appelles-tu page ? c'est un onglet ou une page d'édition ?

Avec les formules matricielles il est tout à fait possible de gérer des classements sportifs (buteurs ou équipes, etc) mais il faut que les données soient enregistrées de façon à permettre leur utilisation.