NB.SI en fonction de 2 critères sur 2 plages [Résolu/Fermé]

Signaler
Messages postés
6
Date d'inscription
mardi 13 janvier 2015
Statut
Membre
Dernière intervention
8 avril 2015
-
Messages postés
6
Date d'inscription
mardi 13 janvier 2015
Statut
Membre
Dernière intervention
8 avril 2015
-
Bonjour à Tous,

Je souhaiterais pouvoir calculer sur le tableau en PJ Le nombre de jours d'ouverture en fonction de ces 2 critères:

- Sur la ligne (M4:AL4) les cellules correspondant aux Mercredis sont remplies
- ET que ne soit pris en compte que les cellules nommées "ME" en ligne (M1:AL1)

Je voudrais faire de même pour les samedis (Nommés "S") et les soirs en Semaine (Nommés "Soirs")

Le tableau est dans le feuillet

https://www.cjoint.com/?0DilAo0MFB2

Merci d'avance de votre aide

3 réponses

Messages postés
6
Date d'inscription
mardi 13 janvier 2015
Statut
Membre
Dernière intervention
8 avril 2015

Plus Exactement Je veux savoir:

- Combien de mercredis Ouverts
- Combien de Samedi Ouverts
- Combien de Soirs Ouverts

Cela en fonction du nombre d'heures d'ouvertures pour chaque jours.

En effet, je dois faire cela pour tous les mois de l'année, pour 3 structures
Messages postés
25810
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 781
Bonjour
pas tout compris, mais vu la demande, pour calculer combien de colonnes nommées ME en M1 AL1 contiennent une valeur en M4:AL4

=NB.SI.ENS($M$1:$AL$1;"ME*";$M4:$AL4;"<>")

mais vous pouvez aussi avoir ça directement avec les dates en ligne 1
si vous placez une ligne de date en M1:AL1 au format date Excel:

=SOMMEPROD(JOURSEM($M$1:$AL$1;2)=3)*($M4:$AL4<>""))


=1 pour lundi, =2 pour mardi, ect

crdlmnt



Errare humanum est, perseverare diabolicum
Messages postés
6
Date d'inscription
mardi 13 janvier 2015
Statut
Membre
Dernière intervention
8 avril 2015

C'était pas très clair mais tu as bien identifié ma demande ET Trouvé la solution!

Merci !