Formule NB.SI sur plusieurs plages [Résolu/Fermé]

Signaler
Messages postés
17
Date d'inscription
dimanche 18 novembre 2012
Statut
Membre
Dernière intervention
24 octobre 2016
-
Messages postés
17
Date d'inscription
dimanche 18 novembre 2012
Statut
Membre
Dernière intervention
24 octobre 2016
-
Bonjour,

Après de multiples recherches, je n'ai pas l'impression d'avoir trouvé une solution à mon problème. Je vous le soumets :

J'aimerais utiliser la fonction NB.SI pour compter le nombre de fois qu'apparait le nom d'un agent, mais sur plusieurs plages de plusieurs feuilles différentes.

Exemple : combien de fois y'a-t-il le nom d'un agent, par exemple DUPONT, entre la plage A5 et M5 de la 'Feuille1', ainsi que entre la plage A5 et M5 de la 'Feuille2' ... Et ce sur 12 feuilles différentes !

L'inconvénient est que j'ai une longue liste d'environ 100 agents à laquelle je dois développer ma formulaire.

J'ai bien trouvé une solution à travers une formule SOMMEPROD que voici :

=SOMMEPROD((Janvier!E5:Janvier!AO5="DUPONT")+(Février!E5:Février!AO5="DUPONT")+(Mars!E5:Mars!AO5="DUPONT")+(Avril!E5:Avril!AO5="DUPONT")+(Mai!E5:Mai!AO5="DUPONT")+(Juin!E5:Juin!AO5="DUPONT")+(Juillet!E5:Juillet!AO5="DUPONT")+(Août!E5:Août!AO5="DUPONT")+(Septembre!E5:Septembre!AO5="DUPONT")+(Octobre!E5:Octobre!AO5="DUPONT")+(Novembre!E5:Novembre!AO5="DUPONT")+(Décembre!E5:Décembre!AO5="DUPONT"))

L'inconvénient est que je ne peux pas développer cette formule à ma liste d'agents, car il me faudrait pour chaque agent changer le nom de l'agent... Sur une liste de 100 personnes, c'est assez indigeste.
Et en sachant qu'en mettant le nom de la cellule (par exemple, à la place de "DUPONT", mettre "Feuille13!C4" (cellule dans laquelle il y a le nom DUPONT)) où il y a le nom de l'agent, ça ne fonctionne pas.

En espérant avoir été suffisamment clair =)
Merci d'avance, n'hésitez pas à si vous avez besoin de précisions.

Cordialement,

Mowkey

3 réponses

Messages postés
25367
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 521
Bonjour
sur la feuille 13
=NB.SI(Janvier!E5:AO5;C4)+NB.SI(Février!E5:AO5;C4)+ ect...
devrait fonctionner si le nom des agents est bien écrit de la même façon dans C4 feuil13 et les lignes A5:M5

(SOMMEPROD((....))aussi, mais il n'est pas utile de répéter le nom de la feuille sur chaque limite de champ _ Feuil1!A5:M5 par exemple convient parfaitement

crtdlmnt

Errare humanum est, perseverare diabolicum
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
17
Date d'inscription
dimanche 18 novembre 2012
Statut
Membre
Dernière intervention
24 octobre 2016

Nickel ! Merci beaucoup Vaucluse !
J'ignorais que l'on pouvait combiner des formules avec le "+".
C'est parfait, merci pour votre réactivité !

Bonne journée !

Mowkey
Messages postés
5518
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
7 octobre 2020
497
Bonjour

Avec Sommeprod

=SOMMEPROD((Janvier!$E$5:$AO$5=A11)+(février!$E$5:$AO$5=A11)+(Mars!$E$5:$AO$5=A11)+(Avril!$E$5:$AO$5=A11)+(Mai!$E$5:$AO$5=A11))ect...

en colonne A mettre la liste des noms et en B cette formule (à prolonger jusqu'à décembre
Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 284
Bonjour,

=SOMMEPROD(NB.SI(INDIRECT("'"&{"Feuil1";"Feuil2";"Feuil3"}&"'!A1:D3");"DUPONT"))

Autre possibilité, tu peux saisir dans une plage le nom des tes onglets, exemple si tu as 12 feuilles, en P1 Janvier, en P2 Février etc .... pas de cellule vide dans cette plage

=SOMMEPROD(NB.SI(INDIRECT("'"&P1:P12&"'!E5:AO5");"DUPONT"))

en nommant la plage ou sont saisi les feuilles exemple plage P1:P12 nommée Feuille et le critère saisi en Q1

=SOMMEPROD(NB.SI(INDIRECT("'"&Feuille&"'!A1:D3");Q1))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.