[Excel] Formule Cellule avec chiffre et texte

Résolu/Fermé
anixela
Messages postés
252
Date d'inscription
vendredi 1 décembre 2006
Statut
Membre
Dernière intervention
1 juin 2018
- 8 nov. 2007 à 22:19
 maged - 27 janv. 2021 à 12:49
Bonsoir,

Je me permets de vous solliciter parce que je n'ai pas réussi à trouver une réponse à mon problème.

Je vous explique tout ça :
- La colonne A peut contenir soit un chiffre soit du texte (qui est variable)
- La colonne B contient un nombre
- La colonne C (c'est là que tout se gâte) doit contenir : dans le cas où A=un chiffre, le résultat de A*B et dans le cas où A=du texte alors on met 0.

Mon problème est que je ne sais pas comment traduire en langage excel la phrase suivante : "Si Ax est un chiffre alors faire Ax*Bx sinon mettre 0".
Je sais que je dois utiliser la fonction SI(critère; valeur si vrai; valeur si faux).

Pouvez-vous m'aider à traduire le critère ?

Je vous remercie pour l'aide que vous m'apporterez.

Bonne nuit à tous
Anixela

10 réponses

gbinforme
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 606
Modifié le 14 déc. 2018 à 23:11
bonjour

Cette formule devrait te convenir. on regardes si A est numérique ESTNUM(A1) et si oui on multiplie sinon zéro.
=SI(ESTNUM(A1);B1*A1;0)



toujours zen
49
jeanchristof
Messages postés
1
Date d'inscription
dimanche 29 novembre 2015
Statut
Membre
Dernière intervention
29 novembre 2015

29 nov. 2015 à 14:00
Bonjour, Nouveau sur ce forum, je suis désolé de revenir sur cette ancienne et excellente réponse, mais ça ne fonctionne pas à tous les coups. Dans mon cas, la case A1 est un nombre qui provient d'une fonction "Alea()" ... le résultat de ma multiplication (B1*A1) est 2 fois sur 3 FAUX, ou en PLUS ou en MOINS . Je n'arrive pas à trouver la solution. Merci d'avance aux connaisseurs, pour votre réponse. JC
0
The Engineer
11 mai 2016 à 10:09
Bonjour,
Je reviens sur cette ancienne question.
A mon humble avis, il est plus simple d'utiliser la fonction "N".
La formule devient, dans la colonne C1 :
=N(A1)*B1
...si que je ne m'abusationnasse point.
0
Merci :)
0
merci
0