Excel somme.si condition multiple [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
jeudi 10 avril 2008
Statut
Membre
Dernière intervention
10 avril 2008
-
Messages postés
526
Date d'inscription
mardi 11 mai 2010
Statut
Membre
Dernière intervention
16 février 2019
-
Bonjour,


j ai un petit pb avec excel. Comment utiliser une fonction si avec ciritères multiple.

vola mon pb

A B
1 100
2 200
3 300
4 400

Dans une colonne B5 j 'aimerais avoir la Somme des B si A est compris entre 2et 4.

j'espere avoir etait Claire Merci d’ava

7 réponses

Messages postés
1676
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
486
Salut,
regarde si ça te convient :
=SOMME.SI.ENS(B:B;A:A;">=2";A:A;"<=4")
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61756 internautes nous ont dit merci ce mois-ci

Messages postés
526
Date d'inscription
mardi 11 mai 2010
Statut
Membre
Dernière intervention
16 février 2019
49
Merci très pratique effectivement :)
Messages postés
51903
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020
13 633
On peut légèrement raccourcir la formule de LePierre
=SOMME.SI(A1:A4;"<=4";B1:B4)-SOMME.SI(A1:A4;"<2";B1:B4)
La fonction proposée par chtilou n'est apparue qu'à partir de la version 2007 d'Excel.
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61756 internautes nous ont dit merci ce mois-ci

Messages postés
1676
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
486
Salut Raymond,
comment va notre retraité antillais?
Messages postés
250
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
2 août 2012
313
bonjour Raymond
j'ai rectifié ta formule pour obtenir le résultat souhaité (Somme des B si A est compris entre 2et 4) en considérant que les lignes 2 et 4 sont exclues :
=SOMME.SI(A1:A4;"<4";B1:B4)-SOMME.SI(A1:A4;"<=2";B1:B4)

à plus

Bonjour,
la solution des formules matricielles n'a pas encore été proposée.
On peut entre la formule {=SOMME((A1:A4>=2)*(A1:A4<4)*B1:B4)}.
Entrer la formule sans les parenthèses puis Ctrl+Maj+Enter.
Messages postés
4
Date d'inscription
jeudi 10 avril 2008
Statut
Membre
Dernière intervention
10 avril 2008

Merci Bcp

Mais j ai pris un exemple un assez simple, dans le cadre de mon travail je ne peut apliquer cet astuce car je v repeter plusieur fois la meme operation sur une meme feuille:

A B
1 12
2 14
3 26
. X
. Y
. Z
10000 42

sur la ligne 4 je veut la somme des b si A et apartient à l intervalle [2;3]

sur la ligne 100 je veut la somme des b si A appartient à l intervalle [40;50]

ect

Mais merci quand meme
Messages postés
1676
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
486
Je ne vois pas trés bien le probléme.
Si tes données ne sont pas trop personnelles transfert ton fichier ici :
http://www.cijoint.fr/index.php
Messages postés
250
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
2 août 2012
313
bonjour

colle en B5 la formule :
=SOMME(B1:B4)-SOMME.SI(A1:B4;"<= 2";B1:B4)-SOMME.SI(A1:B4;">=4";B1:B4)

il y a peut être mieux (en ajoutant la condition dans Somme.si) mais je ne connais pas

à plus
Messages postés
4
Date d'inscription
jeudi 10 avril 2008
Statut
Membre
Dernière intervention
10 avril 2008

Merci

mais je n 'arrive pas à utilisée la formule excel semble ne pas la reconnaitre.

je v m 'acharner un peu car ca semble etre ca
Messages postés
1676
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
486
Regarde ici :
http://www.cijoint.fr/cjlink.php?file=cj200804/cij9OxJ6rg.xls
Messages postés
51903
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 juillet 2020
13 633
Ce que tu demandes au post 3 n'est plus du tout le problème posé au départ !
Il te suffit de saisir en B4 =SOMME(B2:B3) et en B100 =SOMME(B40:B50) ...
Je ne vois pas où est la difficulté, à moins que tu en sois à tes tous premiers pas dans Excel !
Messages postés
4
Date d'inscription
jeudi 10 avril 2008
Statut
Membre
Dernière intervention
10 avril 2008

En fait Si

car je travaille a partir d une macro qui impute une balance comptable dans différentes feuilles 3 à 10

or j aimerais l ' ameliorer avec des sous totaux

Mais comme dans ces feuilles à la base il n'y a rien c'est la seul solution que j'ai trouver c de rajouter la formule somme.si dans c feuilles 3 à 10 de bases avant imputation.

n' ayant pas encore les competance en vba pour la modifier.

desolé de pas etre plus clair. je prendrai plus de temps un autre jour pour exposer mon probléme car je suis un peu charette aujourd'hui comme on dit

Mais merci bcp de votre aide. je sent que je v devenir un habituer de ce site en esperant pouvoir rendre l appareil un jour car c vraiment une mine d 'infrormation

Ps mon excel ( 2003) ne connait pas la fonction SOMME.SI.ENS elle n apparait pas dans la liste des fonction.