Somme dans excel toujours =0 [Résolu/Fermé]

Signaler
Messages postés
53
Date d'inscription
jeudi 25 septembre 2003
Statut
Membre
Dernière intervention
14 mars 2008
-
 jonas -
bonjour,
j'essai d'aditionner des cellules dans excel et il me met quelque soit les nombre aditioné 0. Qu'est qui peu bien se passer ,
Merci

12 réponses

Pour ce qui est des calculs sur excel
vous devez vérifier si c'est une ponctuation
comme exemple 25.50 ou 25,50 les nombres doit etre inscri avec une virgule pour calculer une celule
vous devez enlevez vos point
20
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 93598 internautes nous ont dit merci ce mois-ci

Messages postés
1227
Date d'inscription
jeudi 29 juillet 2004
Statut
Contributeur
Dernière intervention
25 novembre 2013
425
Salut,

Tes cellules sont-elles au format nombre ???

A+
Peut-etre que dans ta formule tu additionne la cellule ou tu mets ton résultat.
Ça m'est arrivé et ça été long à trouver, mais fait afficher tes formules et tu verras si ta cellule ou tu as ta formule est dans la formule.
Salut,
il se peut que le contenu des cellules est alpha-numérique : un blanc au début ou entre les caractères ; il apparait que c'est un nombre, mais en réalité il ne l'est pas
Bon travail
Messages postés
53
Date d'inscription
jeudi 25 septembre 2003
Statut
Membre
Dernière intervention
14 mars 2008
30
effectivement lorsque que je faisait un cliq droit , format de la cellule, le formay était "nombre", mais le contenu était toujours en format texte. J'ai donc converti le texteen nombre et là ça marche impecablement.
Merci beaucoup pour votre aide.
@ tchao
Salut

Recopie nous ta formule, qu'on puisse vérifier la syntaxe

@+
Messages postés
53
Date d'inscription
jeudi 25 septembre 2003
Statut
Membre
Dernière intervention
14 mars 2008
30
oui toutes mes cellules sont bien au format nombre.
la syntaxe est =g15+g52.
a plus tard
Sympa + tompols
dit moi faissalc en faisant simple tu tape tes decimales avec un "point" ou une "virgule", ton prob vient peut etre de la !!!
par default , c'est la "virgule"qui joue le role de separateur decimal si tu veut changer la virgule en point va changer dans les paramettre regionnaux le point comme separateur decimal ...
Messages postés
53
Date d'inscription
jeudi 25 septembre 2003
Statut
Membre
Dernière intervention
14 mars 2008
30
salut c encore moi.

J'ai remarqué que lorsque je choisi une cellule avec un nombre non décimal donc entier, il n'y a pas de probleme . Dès que je choisi une cellule avec un nombre à virgule la somme est égale à zéro quelque soit le nombre.
merci
@+
Messages postés
290
Date d'inscription
jeudi 24 février 2005
Statut
Membre
Dernière intervention
2 avril 2010
45
Je viens de faire un petit test sur 4 cellules, cela fonctionne avec la formule ci-dessous:

=SOMME(A1:A4)
j'ai suivi vos réactions, mai j'ai fais le contraire:
ne pas mettre de vergules; plutôt des points pour les décimales; ça marche.
Messages postés
2
Date d'inscription
lundi 23 avril 2012
Statut
Membre
Dernière intervention
23 avril 2012
8
Bonjour, j'ai également un problème avec un tableau Excel.
Mon tableau comprend plusieurs calculs avec des formules et au final, lorsque j'essaye d'additionner les résultats de mes divers calculs, j'ai toujours le résultat "0" qui apparaît.

Plus précisément, lorsque les sommes que j'additionnes sont toutes supérieurs à "0", le résultat apparaît normalement mais il suffit qu'une seule de mes cases à additionner soit égale à "0" pour que le résultat final soit toujours égal à "0"...

PS: Je précise que j'ai vérifié et qu'il n'y a pas de problème de virgule ou de point.

Merci d'avance !
oui vous avez raison, lorsque je retire la classe contenant le zéro de ma formule, j obtiens le résultat correct ! alors ma question est pourquoi la cellule contenant 0 pause des problèmes
Messages postés
4
Date d'inscription
jeudi 5 mars 2015
Statut
Membre
Dernière intervention
5 mars 2015

Bonjour, je rencontre également un soucis, je souhaiterais faire le total de plusieurs cellules contenant toutes la même formule, j'ai essayé en mettant une virgule, en enlevant les guillemet mais rien à faire. Je suis sur Office 2010 :

Voici ma formule:

=SI(E4:E49="iPhone 5C Blanc 8Go";"1,0";SI(E4:E49="iPhone 5C Bleu 16Go";"69,9";SI(E4:E49="iPhone 5S Gris 16Go";"119,9";SI(E4:E49="iPhone 5S Argent 16Go";"119,9";SI(E4:E49="iPhone 5S Gris 32Go";"159,9";SI(E4:E49="iPhone 6 GRIS SIDERAL 16Go";"199,9";SI(E4:E49="iPhone 6 GRIS SIDERAL 64Go";"289,9";SI(E4:E49="iPhone 6 GRIS SIDERAL 128Go";"379,9";SI(E4:E49="iPhone 6 PLUS GRIS SIDERAL 16Go";"289,9";SI(E4:E49="iPhone 6 PLUS GRIS SIDERAL 64Go";"379,9";SI(E4:E49="iPhone 6 PLUS GRIS SIDERAL 128Go";"469,9";SI(E4:E49="Samsung Galaxy Young 2";"1,0";SI(E4:E49="Samsung Grand Prime";"1,0";SI(E4:E49="Samsung Galaxy A3";"1,0";SI(E4:E49="Samsung Galaxy S5 Active";"69,9";SI(E4:E49="Samsung Galaxy S5 4G+ noir";"64,9";SI(E4:E49="Samsung Galaxy Alpha Or";"134,9";SI(E4:E49="Samsung Galaxy Note 4";"214,9";SI(E4:E49="Samsung Galaxy Note Edge";"339,9";SI(E4:E49="Samsung Galaxy Alpha Argent";"134,9";SI(E4:E49="Sony Xperia Z3 Compact noir";"1,0""")))))))))))))))))))))

Lorsque je fais un total malgré que cela soit bien rempli, cela reste à 0, mais quand je fais un test en mettant tout simplement un nombre "20" le total fonctionne.
Toutes tes valeur doivent être au même format, il faut toutes les vérifier.
Messages postés
136
Date d'inscription
vendredi 10 octobre 2008
Statut
Membre
Dernière intervention
11 octobre 2012
2
merci les amis
aprés une vérification de la ponctuation, j'ai constaté ke le probléme est à ce niveau , une fois ke j'ai changé les virgules par les points ,la somme est exacte. on peut aussi changer le symbole décimal depuis le panneau de configuration.

merci