MFC sur plage de données

Résolu/Fermé
HyaKai Messages postés 4 Date d'inscription mardi 14 décembre 2021 Statut Membre Dernière intervention 15 décembre 2021 - 14 déc. 2021 à 18:53
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 - 14 déc. 2021 à 20:03
Bonjour,

Je rencontre une petite difficulté sur une mise en forme conditionnelle :

J'ai un ensemble de cellules (H11:Z110) et une colonne (AA11:AA110). J'aimerai que les cellules qui sont identiques à une des valeurs de la colonne AA se décolore.

J'ai réussi jusqu'ici à colorer les cellules H:Z en vert si j'y rentre un nombre.

J'ai également réussi à décolorer certaines cellules en rentrant un nombre dans la cellule AA11. Mais si je rentre un autre nombre dans une des autres cellules de la colonne AA cela ne marche plus...

J'ai rentré comme formule dans la MFC : Valeur de la cellule = ($AA$11:$AA$110), appliquée à $H$11:$Z$110.

J'arrive à faire cette MFC mais manuellement (soit cellule par cellule de AA...). N'y aurait-il pas un moyen automatiser cela?

Merci!

2 réponses

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 399
Modifié le 14 déc. 2021 à 20:07
Bonjour
formule de MFC à tester à défaut d'en connaître plus

en sélectionnant H11:Z110
pour une MFC détectant ligne par ligne seulement:
=$AA11=H11
formate les cellules contenant la valeur de AA11 sur la ligne 11

pour une MFC traitant toute la plage selon la liste en AA
=NB.SI($AA$11:$AA$110;H11)
forate toutes les cellules de la plage qui contiennent une des valeurs de AA11àAA110

attention aux signes $
crdlmnt

0
HyaKai Messages postés 4 Date d'inscription mardi 14 décembre 2021 Statut Membre Dernière intervention 15 décembre 2021
14 déc. 2021 à 19:26
Top merci! Pour la rapidité et la réponse !!

C'est la deuxième formule que je recherchai et cela fonctionne top!

Juste pour comprendre, peux-tu m'expliquer comment fonctionne ta formule?

Et pourquoi la formule que j'avais rentré de base ne marchait pas?

Merci :)
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 399
14 déc. 2021 à 20:03
le code NB.SI(champ;cellule) compte le nombre de fois où la valeur de la cellule est contenue dans le champ
exemple pour compter des valeurs texte zzz dans la colonne A, une formule en B1:
=NB.SI(A:A;"ZZZ")

pour la MFC, la formule
=NB.SI($AA$11:$AA$110;H11)
trouve si le champ AA contient la valeur de H11quelque part dans la liste AA une ou plusieurs fois, et si le résultat est >0, applique le formatage
peux pas dire plus!
Crdlmnt
0