Reporter valeur sur autre feuille avec critere

Fermé
Otk168
Messages postés
3
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
23 août 2017
- 22 août 2017 à 13:17
via55
Messages postés
13593
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 mai 2022
- 23 août 2017 à 21:58
Bonjour à tous,

Je suis débutant sur Excel, j'essaye d'apprendre petit a petit les formules simples et complexes.
Mon problème est le suivant :
Mon classeur est composé de 2 feuilles, dans la première se trouve une "base de données" sur 2 colonnes ( la première donne une référence et la deuxième un code associé à cette reference)
Dans la deuxième feuilles, il y a un ensemble de ligne avec une colonne contenant la référence (celle de la première feuille).
J'aimerais une formule permettant d'aller chercher pour chaque référence le code associé sur la page 1 et le reporter sur la page 2.
Jespere avoir été assez clair et explicit sur ce problème.

Merci par avance de votre aide
A voir également:

1 réponse

via55
Messages postés
13593
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 mai 2022
2 400
22 août 2017 à 13:37
Bonjour

Tu dois utiliser RECHERCHEV

=RECHERCHEV(A1;Feuil1!A:B;2;0)

A1 étant la valeur cherchée
Feuil1!A:B le tableau où chercher
2 la colonne de l'info à retourner
0 exige une correspondance exacte

Cdlmnt
Via
0
Otk168
Messages postés
3
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
23 août 2017

22 août 2017 à 17:44
Merci beaucoup j'ai essayé et cela fonctionne à merveille.
0
Otk168
Messages postés
3
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
23 août 2017

23 août 2017 à 20:35
Désolé je vais etre un peu embêtant mais cette formule fonctionne t elle pour renvoyer des lignes entieres?
0
via55
Messages postés
13593
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 mai 2022
2 400 > Otk168
Messages postés
3
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
23 août 2017

23 août 2017 à 21:58
Re,

Pour renvoyer plusieurs colonnes tu agrandis le tableau de départ
Feuil1!A:D pour renvoyer les valeurs des col B à D par ex
Ensuite tu changes le n° de colonne à renvoyer dans la formule dans les colonnes d'arrivée, 2 pour retourner la valeur de la col B, 3 celle de la C etc
0