Formule dépassement délai de paiement

Résolu/Fermé
Floweroftea1
Messages postés
11
Date d'inscription
samedi 20 février 2021
Statut
Membre
Dernière intervention
23 février 2021
- 20 févr. 2021 à 19:19
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
- 20 févr. 2021 à 21:51
Bonsoir
j'ai créé la formule suivante avec la fonction "si" : =SI([@Solde]>0;SI([@[J+]]=0;"Ne rien faire";""))
mais je n'arrive à créer la suite, cad : >10; >15, etc.....
n'est-ce pas la bonne fonction ?

8 réponses

Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
20 févr. 2021 à 19:27
Bonjour,

votre formule est incohérente !

Que voulez-vous précisément faire et avec quelles conditions ?
0
Floweroftea1
Messages postés
11
Date d'inscription
samedi 20 février 2021
Statut
Membre
Dernière intervention
23 février 2021

20 févr. 2021 à 19:29
je veux que si ma valeur J+ (jours de dépassement) soit = 0 xl me marque : ne rien faire, si la valeur est >10 xl me marque : relance 1, etc.....
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
Modifié le 20 févr. 2021 à 19:38
Nous ne pouvons nous satisfaire de etc....., si voulez la meilleure aide !

Cependant, avec le peu d'infos :

A1 à adapter

=SI(A1=0;"Ne rien faire";SI(A1>10;"Relance 1";SI(A1...


ATTENTION, il faudra rajouter la fonction ET pour un meilleur résultat, toujours à titre indicatif :

=SI(A1=0;"Ne rien faire";SI(ET(A1>10;A1<=15);"Relance 1";SI(A1...
0
Floweroftea1
Messages postés
11
Date d'inscription
samedi 20 février 2021
Statut
Membre
Dernière intervention
23 février 2021

20 févr. 2021 à 20:05
bonsoir, merci, pouvez-vous vérifier ma formule : =SI(Q6<0;"OK";SI(Q6=0;"Ne rien faire";SI(ET(Q6>10;Q6<=15);"Relance 1";SI(ET(Q6>16;Q6<=30);"Relance 2" ; SI(ET(Q6>31;Q6<=45);"Relance 3";SI(ET(Q6>46;Q6<=60);SI(ET(Q6>61;Q6<=90);"Mise en poursuite"))))))
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
20 févr. 2021 à 20:24
Pour vous, elle fonctionne ?

Peut-on avoir des valeurs :
entre 1 et 10 ?
égale à 16 ?
pour
SI(ET(Q6>46;Q6<=60)
, il n'y a pas de valeur de renvoi, si les conditions sont vraies.
0
Floweroftea1
Messages postés
11
Date d'inscription
samedi 20 février 2021
Statut
Membre
Dernière intervention
23 février 2021

20 févr. 2021 à 20:30
non, elle ne fonctionne pas.... bon j'ai vu que j'avais laissé des espaces, etc... mais même en corrigeant, cela ne change rien.
pas compris votre question des valeurs ?
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Floweroftea1
Messages postés
11
Date d'inscription
samedi 20 février 2021
Statut
Membre
Dernière intervention
23 février 2021

20 févr. 2021 à 20:34
est-ce que cette formule a l'air de tenir la route, merci de vos commentaires :
=SI(Q6<0;"OK";SI(Q6=0;"Ne rien faire";SI(ET(Q6>0;Q6<=10);"Relance 1";SI(ET(Q6>11;Q6<=30);"Relance 1";SI(ET(Q6>31;Q6<=60);"Relance 2";SI(ET(Q6>61;Q6<=90);"Relance 3";SI(ET(Q6>91;"Poursuite1"))))))
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
20 févr. 2021 à 20:44
Rectification de votre formule :

=SI(Q6<0;"OK";SI(Q6=0;"Ne rien faire";SI(ET(Q6>0;Q6<=10);"Relance 1";SI(ET(Q6>=11;Q6<=30);"Relance 1";SI(ET(Q6>31;Q6<=60);"Relance 2";SI(ET(Q6>61;Q6<=90);"Relance 3";"Poursuite1"))))))
0
Floweroftea1
Messages postés
11
Date d'inscription
samedi 20 février 2021
Statut
Membre
Dernière intervention
23 février 2021

20 févr. 2021 à 20:39
formule corrigée :
=SI(Q6<0;"OK";SI(Q6=0;"Ne rien faire";SI(ET(Q6>0;Q6<=10);"Relance 1";SI(ET(Q6>11;Q6<=30);"Relance 2";SI(ET(Q6>31;Q6<=60);"Relance 3";SI(ET(Q6>61;Q6<=90);"Menace de poursuite";SI(ET(Q6>91;"Mise en poursuite")))))))
0
Floweroftea1
Messages postés
11
Date d'inscription
samedi 20 février 2021
Statut
Membre
Dernière intervention
23 février 2021

20 févr. 2021 à 21:08
la formule ne fonctionne pas, je ne sais pas pourquoi. Peut-on envoyer des fichiers sur ce forum ?
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
20 févr. 2021 à 21:19
La fonction ET est utile seulement quand on cherche 2 conditions (ou plus)
Quand il n'y a qu'une condition, elle n'est pas utile.

Votre dernière formule doit donc être écrite ainsi :

=SI(Q6<0;"OK";SI(Q6=0;"Ne rien faire";SI(ET(Q6>0;Q6<=10);"Relance 1";SI(ET(Q6>11;Q6<=30);"Relance 2";SI(ET(Q6>31;Q6<=60);"Relance 3";SI(ET(Q6>61;Q6<=90);"Menace de poursuite";"Mise en poursuite"))))))


Si elle ne vous va toujours pas, merci de donner quelles conditions doivent renvoyer quelles vrai
0
Floweroftea1
Messages postés
11
Date d'inscription
samedi 20 février 2021
Statut
Membre
Dernière intervention
23 février 2021

20 févr. 2021 à 21:49
non c'est nickel. tout fonctionne à merveille avec une petite modification faîte automatiquement par xl... merci et bonne soirée. Peut-on envoyer des fichiers sur ce forum ?
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
20 févr. 2021 à 21:51
Si tous est OK, merci de passer votre sujet en [Résolu]

Pour les prochaines fois, vous avez la possibilité de partager votre fichier via https://www.cjoint.com/
Et ensuite revenir ici en collant le lien généré.

Bonne soirée :-)
0