Comment faire une RECHERCHEV sur une base avec début des données ? [Résolu]

Signaler
Messages postés
2
Date d'inscription
mardi 16 février 2021
Statut
Membre
Dernière intervention
17 février 2021
-
Messages postés
2
Date d'inscription
mardi 16 février 2021
Statut
Membre
Dernière intervention
17 février 2021
-
Bonjour,

Je cherche à renseigner dans une colonne B les types de motorisations des véhicules listés dans la colonne A.
Je pensais donc utiliser la fonction RECHERCHEV avec une base listant le début des noms de véhicules hybrides (information que je souhaite faire ressortir). Or, je ne parviens pas à trouver une formule qui recherche une correspondance sur le début d'une cellule.
Je joins un fichier exemple pour illustrer mon problème.
https://www.cjoint.com/c/KBqqwdVFoCi

Merci pour toute aide qui pourra m'être proposée !

3 réponses

Messages postés
8435
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 février 2021
1 610
Bonjour,

En B2 :
=SIERREUR(INDEX(Tables!$B$2:$B$8;SOMMEPROD((NBCAR(SUBSTITUE(A2;Tables!$A$2:$A$8;""))<NBCAR(A2))*LIGNE($1:$7)));"Thermique") 

Messages postés
25817
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 784
Bonjour (et salut Patrice)
peut être un peu plus simple ici, mais attention votre liste de table comportait deux fois le même code en A, ce que la formule ne supporte pas, pas plus que des blancs dans cette liste
J'en ai supprimé un des deux
attention aussi à l'adresse de INDEX dans la formule qui commence forcément en ligne 1, sinon il faut entrer une correction (SOMMEPROD ressort le N° de ligne de la feuille, pas de la plage)
https://mon-partage.fr/f/YKuy698w/
crdlmnt

Messages postés
2
Date d'inscription
mardi 16 février 2021
Statut
Membre
Dernière intervention
17 février 2021

Merci @Vaucluse et @Patrice !
La formule fonctionne parfaitement, charge à moi de comprendre comment maintenant :)