[Excel] Recherche de Texte avec RechercheV

Résolu/Fermé
Mafia06 - 21 janv. 2008 à 16:03
 P-A - 20 nov. 2014 à 11:35
Bonjour,

j'aimerai que ma formule rechercheV recherche du Texte et non une valeur est-ce possible ?

2 réponses

gbinforme Messages postés 14935 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 628
24 avril 2010 à 23:16
bonjour

la valeur recherchée existe bien dans la table de référence

Sans doute que non si tu obtiens "#N/A" : tes données comportent probablement des espaces en fin de zone et tu devrais faire un F2 sur la cellule pour voir qu'ils sont effectivement présents.
3
Laurento Messages postés 4 Date d'inscription jeudi 21 mai 2009 Statut Membre Dernière intervention 5 mai 2010
Modifié par Laurento le 5/05/2010 à 18:59
Bonjour,

Merci pour ton aide.

En fait, l'erreur est bête... plutôt que de nommer la table de référence, elle a été sélectionnée de la manière suivante =RECHERCHEV(M3; table!A130:B494; 2; FAUX); par conséquent en étirant la sélection la table de référence glissait également!
Conclusion: =RECHERCHEV(M3; table!$A$130:$B$494; 2; FAUX).
0
Bonjour Laurento,

J'avais le même problème que toi car, dans la table de référence, les valeurs à rechercher étaient précédés de '.
J'ai sélectionné l'ensemble de la colonne et convertit en nombre...

Si ça peut servir à quelqu'un!
0