[Calc] Somme si une plage de cellule contient une partie de texte [Résolu]

Signaler
-
Messages postés
2900
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 novembre 2020
-
Bonjour,

Je cherche à faire une somme sous Calc, mais seulement sur une partie de texte dans une plage de cellules.

Un exemple étant plus parlant, je recherche la fonction suivante, mais sous Calc :
https://waytolearnx.com/2019/08/somme-si-une-plage-de-cellule-contient-une-partie-de-texte-excel.html

Quelqu'un a déjà été confronté à cette difficulté ?

Merci d'avance pour votre aide.

6 réponses

Messages postés
2206
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
30 novembre 2020
911
Bonsoir
A tester


avec les bonnes options


une aide
Messages postés
2900
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 novembre 2020
785
Bonjour ccdy

Miracle !!! j'ai enfin trouvé la formule pour englober la référence de cellule

=SOMME.SI($D$2:$D$28;"*"&H5&"*";$E$2:$E$28)

Qui fonctionnait sur mon fichier mais pas sur le tien, alors j'ai fouillé sur les réglages calcul il faut cocher le premier Autoriser les caractères génériques dans les formules

https://www.cjoint.com/c/JKbkB6KSlFm

Cordialement
Messages postés
2900
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 novembre 2020
785
Bonjour,

L'avez vous au moins tentée cette formule ?

=SOMME.SI(plage de recherche;"*le texte*";Plage à sommer)

Si difficulté nous faire parvenir la copie du fichier via https://www.cjoint.com/

Cordialement
@PapyLuc51
Bonjour et merci pour votre réponse.
Avant de poster sur un forum et d'importuner les gentils intervenants, je prends le temps de rechercher sur l'aide ou sur le wiki du logiciel en question et, si je ne trouve pas de réponse, de rechercher dans les forums et autres sites web. Je me résous à faire appel à vous, parce qu'après plusieurs heures d'essais et de recherches, je ne suis pas parvenu à trouver de réponse pour cette difficulté, alors que je suis persuadé qu'une solution existe.
L'exemple sous Excel est le seul que j'ai pu trouver et qui corresponde précisément à la difficulté rencontrée, mais ma demande concerne LibreOffice.
Je me permets de vous retourner la question : avez-vous tenté cette formule vous aussi sous LibreOffice ou OpenOffice avant de répondre ?
Messages postés
2900
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 novembre 2020
785
Je ne vois pas où est le problème

Sur LibreOffice Calc v.6.4.6.2 https://www.cjoint.com/c/JJFruPEGMFm

Cordialement
Messages postés
2206
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
30 novembre 2020
911 >
Messages postés
2900
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 novembre 2020

bonsoir papyluc51
sur open office cela ne fonctionne pas
Messages postés
2900
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 novembre 2020
785 >
Messages postés
2206
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
30 novembre 2020

Salut yclik

Il y a longtemps que j'ai abandonné OpenOffice (Màj très espacées), la demande concerne LibreOffice (avant dernière phrase du message #2 de ccdy)

Cordialement
Bonsoir à tous,
Merci infiniment de vous être penché sur ce problème.
Je mets une copie du classeur sur lequel je travaille : https://www.cjoint.com/c/JJFu6xyYi2r
C'est bien du LibreOffice...

PapyLuc51, je suis également sur LibreOffice 6.4.6.2 (Linux Mint 20).
J'ai ouvert votre feuille de calcul, puis j'ai copié vos formules dans ma propre feuille de calcul. Rien ! Nada ! Les Jean sont passés de 70 à 0 !
Ensuite, j'ai copié mes données dans votre feuille de calcul. Et là, c'est un miracle : tout fonctionne...

Ne croyant pas aux miracles, je suis allé voir la réponse de yclik et j'ai découvert que de simples options de caractères pouvaient avoir droit de vie ou de mort sur les formules. Il faut autoriser les caractères génériques dans les formules. Eh bien, j'en apprends une !

Petite cerise sur le nœud de cerveau : y aurait-il moyen de remplacer le texte recherché "*Jean*" par le n° de cellule (H14, dans ma feuille de calcul) ?

Encore merci pour votre efficacité sur ce sujet.
Bonne soirée.
Bonjour à tous,

Encore merci pour vos excellents conseils.

Et comme ces solutions tiennent presque du miracle, j'ai essayé de jouer au petit sorcier à mont tour...

Et là, les bras m'en sont tombés !

Vous m'avez fait découvrir les options de Calc et les formules idoines. Après plusieurs heures de recherches et d'essais en tout genre, j'ai remarqué que la formule différait selon l'option que l'on sélectionnait.

Je rassemble les éléments dans un fichier joint, en espérant qu'il est suffisamment clair :
https://www.cjoint.com/c/JKbrAG2mncr
(mais je ne parviens toujours pas à créer un lien)

Tout ça pour une formule SOMME.SI ! Parfois, on finit par comprendre tous ceux qui en reviennent à la bonne vieille calculatrice, hi, hi, hi...

Bien amicalement,
ccdy
Messages postés
2900
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 novembre 2020
785
Bonjour,
Je viens de voir ton fichier, avec les formules que tu as trouvées sur les deux colonnes en rose ; par contre si tu coches "autoriser les caractères génériques dans les formules" c'est le deux colonnes en bleu qui marquent les bon calculs et les colonnes en rose qui repassent à 0.

Pour créer un lien il faut le mettre entre crochets >>VOIR ICI<<

Pour les liens venant de cjoint il faut faire clic droit sur le lien "copier l'adresse du lien" et venir coller dans le message ; lien du fichier recréé.

https://www.cjoint.com/c/JKbrAG2mncr

Bien cordialement