SOMME.SI.ENS avec une condition sur la date (Mois et Année)

Fermé
LBo - 29 juil. 2019 à 14:37
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 29 juil. 2019 à 17:52
Bonjour,

Je rencontre une difficulté pour exercer un calcul que je pensais "simple". J'aimerais tout simplement additionner les prix de plusieurs objets si leur date de sortie est comprise dans le mois en cours (et pour les mois suivants, mais j'imagine que ce sera la même formule à décliner ou presque).

Je dispose d'un tableau avec les données suivantes : Objet // Date de sortie (plage E3:E123) // Prix (plage J3:J123).

Pour ce faire, j'ai d'abord extrait la date du jour dans une case à part : "29/07/2019".
J'ai ensuite extrait dans 2 cellules distinctes le mois de cette date ("7", en cellule "C128") et l'année ("2019", en cellule "C129").

J'ai ensuite tapé ceci : =SOMME.SI.ENS(J3:J123;E3:E123;"=ANNEE(C129)";E3:E123;"=MOIS(C128)")

Sauf que mon résultat est de... "0,00 €" alors que j'ai bien des objets qui devraient être comptabilisés pour le mois en cours.

Si quelqu'un sait où je pèche, je suis évidemment preneur ! :)

Bonne journée à tous.

Configuration: Windows / Chrome 75.0.3770.142

4 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
Modifié le 29 juil. 2019 à 15:07
Bonjour
SOMME.SI.ENS ne connaîtra pas ces références
essayez avec SOMME.PROD

=SOMME.PROD(ANNEE(E3:E123)=ANNEE(C129))*MOIS(E3:E123)MOIS(C128))*(J3:J123)

ou si vous voulez utiliser SOMME.SI.ENS_ un peu plus compliqué à écrire
=SOMME.SI.ENS(J3:J123;E3:E123;">="&DATE(ANNEE(C129);MOIS(C129);1);E3:E123;"<="&FIN.MOIS(DATE(ANNEE(C291);MOIS(C129);1);0))

crdlmnt

2
Bonjour Vaucluse et merci pour votre aide !

Si la 1ère formule me renvoie de nouveau "0.00 €", la seconde en revanche fonctionne et réalise bien le calcul dont j'avais besoin !

Merci beaucoup pour cette aide précieuse !

Si jamais il vous viens à l'esprit pourquoi la 1ère formule ne fonctionnait pas, je reste preneur tant elle semblait plus "simple" :p

Bonne journée !
0
via55
Messages postés
13799
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
8 août 2022
2 469
29 juil. 2019 à 14:59
Bonjour LBo

Pour obtenir la somme pour juillet 2019 il faut se baser sur la 1ere date du mois et la 1er du mois suivant
=SOMME.SI.ENS(J3:J123;E3:E123;">=" & "01/07/2019";E3:E123;"<" & "01/08/2019")

1° remplace ta formule en C128 par une te donnant le 1er jour du mois :
=DATE(ANNEE(cellule de la date du jour);MOIS(cellule date du jour);1)

2° ta formule SOMME.SI sera alors
=SOMME.SI.ENS(J3:J123;E3:E123;">=" & C128;E3:E123;"<" & MOIS.DECALER(C128;1))

Cdlmnt
Via
0
Bonjour Via et merci pour ton aide.

Malheureusement, ça ne marche toujours pas... :/

Pas de souci concernant la 1ère étape, j'obtient bien "01/07/2019".
En revanche, j'obtiens de nouveau "0,00€" en résultat. C'est à n'y rien comprendre. Mes cellules sont pourtant bien au format "date" et une formule plus simple fonctionne (Par exemple : =SOMME.SI.ENS(J3:J123;E3:E123;">30/07/2019") ).
0
via55
Messages postés
13799
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
8 août 2022
2 469
29 juil. 2019 à 15:43
Postes ton fichier sur mon-partage.fr; copie le lien crée et reviens le colelr ici, j'essaierai de voir ce qui cloche
0
C'est adorable, mais ne t'embête pas ! J'ai une solution viable dans la réponse de @Vaucluse juste au-dessus ! Merci encore pour ton aide, sincèrement :)
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
29 juil. 2019 à 17:52
bonjour
pour appliquer SOMMEPROD correctement, il ne faut pas faire de faute de frappe comme moi, en oubliant quelques parenthèses et un signe égal, et de surcroît en mélangeant 129 et 128

=SOMME.PROD((ANNEE(E3:E123)=ANNEE(C129))*(MOIS(E3:E123)=MOIS(C129))*(J3:J123))

désolé, mais je suis en vacances :-))

crdlmnt
0