Si cellule contient... [Résolu/Fermé]

Signaler
-
 Ludo_du33 -
Bonjour à tous,

Je travaille sur un tableur Google Sheets et je ne trouve pas la formule qui correspond a mon besoin..

En gros, je voudrais afficher dans une cellule un résultat en fonction de la cellule d'à côté si cette dernière contient une partie d'un texte, mais ce texte se trouvant aussi dans une autre cellule..

Par exemple : Si A1 contient ENTRE AUTRES A2 Alors A3.

Je ne sais pas si c'est clair.. Je sais le faire avec du texte (en mettant "*valeur*") mais pas avec le contenu d'une autre cellule..il me manque l'équivalent du "*...*" pour les cellules.

N'hésitez pas si vous avez besoin de précisions.

Merci beaucoup!


3 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 248
Bonjour,

Avec cette formule tu devrais avoir ton résultat :
=SI(NON(ESTERREUR(TROUVE(A2;A1)));A3;"")
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
25627
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 novembre 2020
5 628
Bonjour

remplacez si "*valeur*" par "*"&cell&"*"
cell étant l'adresse de cellule
Mais le code SI ne fonctionne pas avec ce genre d'écriture, il faut passer par NB.SI

=SI(NB.SI(Cell1;"*"&cell2&"*");...

pour info:
"*"&cell&"*" > contient
"*"&cell > se termine par
cell"*" > commence par
crdlmnt



La qualité de la réponse dépend surtout de la clarté de la question, merci!
Super merci beaucoup! Oui j'avais effectivement le Si(nb.si(...)..

C'est ce que je recherchais!
Merci beaucoup