Formule arrondi entier inférieur, supérieur ou 0,5 [Résolu]

Signaler
Messages postés
4
Date d'inscription
mercredi 29 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020
-
Messages postés
2770
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 septembre 2020
-
Bonjour,
Je souhaiterai savoir quelle est la formule pour arrondir à l'entier inférieur (ou supérieur) lorsque la décimale est plus proche de l'entier (jusqu'à +/-0,25) et à 0,5 près lorsque la décimale est plus proche de 0,5...peut être pas très clair, concrètement ça donnerait ça:

6,10 -> 6
6,20 -> 6
6,25 -> 6,5
6,30 -> 6,5
6,40 -> 6,5
6,50 -> 6,5
6,60 -> 6,5
6,70 -> 6,5
6,75 -> 7
6,80 -> 7
6,9 -> 7

Merci d'avance! :)

Configuration: Windows / Chrome 84.0.4147.89

4 réponses

Messages postés
2770
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 septembre 2020
727
Bonjour,

Si j'ai bien compris les décimales <0.25 donnent l'entier du nombre ; >=0.25 et <0.75 donnent l'entier du nombre + 0.50 ; >=0.75 donnent l'entier du nombre +1

Une formule à tenter premier nombre en A1

=SI(A1<>"";SI(MOD(A1;1)<0,25;ENT(A1);SI(ET(MOD(A1;1)>=0,25;MOD(A1;1)<0,75);ENT(A1)+0,5;ENT(A1)+1));"")

Cordialement
Messages postés
2364
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
31 août 2020
873
Bonjour,
À vérifier: =ARRONDI.AU.MULTIPLE(A1;0,5)
Messages postés
4
Date d'inscription
mercredi 29 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020

Merci tongtong!

Ca marche très bien aussi!
Une idée pour renvoyer 0,5 lorsque la valeur est < 0,25, svp?
:)
Messages postés
2364
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
31 août 2020
873 >
Messages postés
4
Date d'inscription
mercredi 29 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020

=MAX(0,5;ARRONDI.AU.MULTIPLE(A1;0,5))
Messages postés
4
Date d'inscription
mercredi 29 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020
>
Messages postés
2364
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
31 août 2020

Parfait!

Merciiii
Messages postés
4
Date d'inscription
mercredi 29 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020

Merci beaucoup PapyLuc51,

pour la réactivité, la compréhension (!) et l'efficacité!

La formule marche parfaitement!

En l'appliquant je me rend compte que les valeurs inférieures à 0,25 donnent 0 ce qui est parfaitement logique. Pouvez vous ajouter une partie qui permettrait de renvoyer 0,5 au minimum lorsque la valeur de A1 < 0,25, svp?
qui donnerait cela:
0,10 -> 0,5
0,24 -> 0,5

Merci!
Messages postés
2770
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 septembre 2020
727
Avec le rajout de A1<0.25

=SI(A1<>"";SI(A1<0,25;0,5;SI(MOD(A1;1)<0,25;ENT(A1);SI(ET(MOD(A1;1)>=0,25;MOD(A1;1)<0,75);ENT(A1)+0,5;ENT(A1)+1)));"")

Cordialement