Mettre à jour le PHP Wordpress sur OVH

Signaler
Messages postés
174
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
9 avril 2020
-
 Utilisateur anonyme -
Bonjour,
Je ne sais pas et comprends mal comment mettre à jour mon PHP Wordpress chez OVH. Il me propose, sur mon tableau de bord la mise à jour 5.4, alors qu'il est dit qu'il faut le 7.3, il me semble. Je ne sais pas ou trouver le programme Wordpress sur mon ordi. Enfin, bref, difficile pour moi. Peut-être une bonne âme veuille bien m'aider ou même faire.


Configuration: Windows / Chrome 80.0.3987.149

4 réponses

Messages postés
1603
Date d'inscription
vendredi 12 avril 2013
Statut
Contributeur sécurité
Dernière intervention
30 avril 2020
186
Hello,

En fait la version de PHP se trouve directement sur le manager : https://www.ovh.com/manager/web/#/configuration/hosting



Tu peux la changer comme ci,

Bon chance,

Alex

Messages postés
174
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
9 avril 2020
4
Bonjour, Alex,
Je suis allé sur mon OVH manager.
J'ai deux sites, l'un ou j'ai accès et me signale que mon changement a été pris en compte, mais l'autre n'a pas PHP 7.0 ou autre pour le mettre en PHP 7.3.

Bonjour,
sur FTP, le fichier .ovhconfig (un seul fichier, à la hauteur du dossier www)
Vous avez bien ce code ?
app.engine=php
app.engine.version=7.3
http.firewall=none
environment=production
container.image=stable
Utilisateur anonyme
Il faut avoir la configuration minimum pour WP
https://fr.wordpress.org/about/requirements/

-PHP version 7.3 ou supérieure.
-MySQL version 5.6 ou supérieure OU MariaDB version 10.1 ou supérieure.
-Prise en charge du HTTPS

La version PHP7.3 chez OVH est indiqué Beta, c'est juste un bug d'affichage, c'est bien une version stable.
Il faut un seul fichier .ovhconfig et il doit être à la hauteur du dossier /www
Si vous voyez d'autres fichiers .ovhconfig les supprimer, cela peut créer des conflits entre eux.
Messages postés
174
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
9 avril 2020
4
Bonjour, Aftermath 16,
C'est un peu latin pour moi. Je vois ça demain, pour ce soir, je te souhaite une bonne soirée ainsi que Dinath.
A demain,
Utilisateur anonyme
Bonjour,
Qu'est ce qui vous paraît plus compliqué ?

- Je vous demande juste, d'ouvrir votre logiciel FTP, de vous connecter à votre serveur, comme pour l'installation de WordPress.
Puis à la hauteur du dossier /www , vous devez voir sil y a un fichier nommé .ovhconfig


Si oui, le téléchargdr sur votre ordinateur, l'ouvrir avec un éditeur de texte comme NotePad++
Et voir le code à l'intérieur, il doit être comme ça
app.engine=php
app.engine.version=7.3
http.firewall=none
environment=production
container.image=stable



Mon autre message, j'explique juste que pour WordPress fonctionne correctement, il faut que votre hébergeur propose ceci, cette configuration minimum.
- PHP7.3
- Pour la base de données : MySQL version 5.6 ou MariaDB version 10.1
- HTTPS pour l'adresse de votre site avec le certificat Let's Encrypt ou SSL, souvent gratuit chez les hébergeurs.
Messages postés
174
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
9 avril 2020
4
Bonjour, Aftermath,
Alors, il faut dire que mon site a été créé en 2011. Toutes les mises à jour ont été faites via mon tableau de bord. Ce n'est pas moi qui ai installé le site Wordpress, mais un ami qui n'est plus accessible.
Faire et remplir des pages et articles, pas de soucis, mais le jour où, sur le tableau de bord, il m'a été demandé de mettre à jour mon PHP, j'ai du mal. D'une part, j'ai changé depuis 2011, deux fois de PC et je doute que le logiciel FTP ait été chargé.
Je te remercie pour tes explications, mais où se trouve ce logiciel ? J'ai bien "Filezella FTP Client" dans "OS (C:)" et "Programmes". Mais je crois qu'il sert à installer un site.
Voilà où j'en suis.
Je veux bien apprendre, mais je pense qu'il me manque des éléments dans le PC et de beaucoup d'expériences.

Messages postés
174
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
9 avril 2020
4 > Utilisateur anonyme




Il semble que je n'ai pas ce que vous me demander.
Utilisateur anonyme >
Messages postés
174
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
9 avril 2020

C'est quoi www2 ?
Sans, vous ne pouvez pas être sous PHP7.3, il faut le créer avec un éditeur de texte comme notepad++
En mettant le code que j'ai donné au dessus.
Et bien le nommer .ovhconfig puis l'envoyer à la hauteur de votre deuxième capture d'écran, là on lit www, www2, ..
Messages postés
174
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
9 avril 2020
4 > Utilisateur anonyme
www2 ? je ne sais pas.
Comme ceci ?


Et je le nomme ".ovhconfig" et je le mets où ? Sur Filezilla ?
Utilisateur anonyme >
Messages postés
174
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
9 avril 2020

oui, comme ça.
oui le nommer .ovhconfig
L' envoyer sur FTP, à la hauteur des dossier www et www2
Si le logiciel FileZilla fonctionne le faire avec.

ps: en message privé, je vous avais envoyé un lien pour télécharger le fichier.
Utilisateur anonyme >
Messages postés
174
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
9 avril 2020

Avant de passer sous PHP 7.3, tous vos plugins doivent être à jour et votre thème aussi.
Il faut des mises à jour vers 2019, le mieux en 2020, pour que cela soit bien compatible avec PHP 7.3.
Sinon cela peut faire bugger votre site.

Bonne soirée