Problème ping D-Link Wireless PCI-e Adapter

Résolu/Fermé
Mr_Skkay
Messages postés
81
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
18 octobre 2018
- 9 mai 2018 à 16:54
Mr_Skkay
Messages postés
81
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
18 octobre 2018
- 18 oct. 2018 à 18:49
Bonjour, depuis quelques semaines j'ai des problèmes avec un adaptateur WiFi (Wireless AC1200 Dual Band PCI Express Adapter) de référence DWA-582.

Exactement toute les 10 secondes, je vais avoir une montée de ping (d'environs 2000 ms), et ce même en local.

Ce n'est pas mon connexion qui déconne, car en Ethernet je n'ai aucune problème.

Je vous met un screen avec le ping (à gauche, en noir c'est en local, à droite c'est sur google.fr)

Mes drivers sont bien à jour, et il y a seulement 1 mètre entre les antennes de l’adaptateur et la box

5 réponses

Mr_Skkay
Messages postés
81
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
18 octobre 2018
50
12 juin 2018 à 20:03
J'ai donc trouvé un solution, certes un peu pénible, mais fonctionnelle :

Il faut désactivé la configuration automatique (mais cela empêche l'affichage des réseaux disponible) :
Exécutez l'invite de commande (cmd) en mode administrateur et taper cette ligne :

netsh wlan set autoconfig enabled=no interface="Wi-Fi 2"


Pour la réactiver :
netsh wlan set autoconfig enabled=yes interface="Wi-Fi 2"




Il est fort probable que le nom d'interface ne soit pas le même pour vous, pour le connaitre :

Panneau de configuration > Réseau et Internet > Centre Réseau et partage
Puis quelque chose de semblable à cela :

Types d'accès : Internet
Connexions : [Le nom d'interface] [(nom du réseau)]



Exemple pour moi :
Types d'accès : Internet
Connexions : [Wi-Fi 2] [(Mon réseau 4G)]





Cette solution fonctionne mais très embêtante car elle empêche l'affichage des réseaux disponible, et donc la connexion / déconnexion au réseau WiFi.
Même en essayant de se connecter en ligne de commande, vous aurez un message d'erreur :

Impossible de se connecter. La configuration automatique du réseau WLAN est
désactivée sur la carte « Wi-Fi 2 ».

Mais vous pouvez tout de même imaginez un script en .bat qui réactive le configuration automatique, puis se connecte / déconnecte au réseau voulu, puis re-désactive la configuration automatique :

Connexion :
netsh wlan set autoconfig enabled=yes interface="WiFi 2"
netsh wlan connect name = "Mon réseau 4G"
netsh wlan set autoconfig enabled=no interface="WiFi 2"

Déconnexion :
netsh wlan set autoconfig enabled=yes interface="WiFi 2"
netsh wlan disconnect interface = "Wi-Fi 2"
netsh wlan set autoconfig enabled=no interface="WiFi 2"


Plus d'infos sur ces dernières lignes :
https://www.pcastuces.com/pratique/astuces/3651.htm
2