Formule Excel SI Cellule contient mots

Résolu/Fermé
FormulaSeeker
Messages postés
13
Date d'inscription
mardi 5 décembre 2017
Statut
Membre
Dernière intervention
5 mars 2018
- 5 déc. 2017 à 19:33
 Duncan - 29 août 2018 à 22:38
Bonjour,

Je suis désespérément à la recherche de la bonne formule qui me permettrait de catégoriser plus d'un millier de magasin :

En A1 j'ai par exemple :
Magasin XXX type Super Adresse XXX
Magasin XXX type Hyper Adresse XXX
Magasin XXX Type Express Adresse XXX
Magasin XXX Type Marché Adresse XXX
Magasin XXX Type Utile Adresse XXX

J'ai donc 5 catégories de magasins différents. Je souhaite qu'en B1 s'affiche uniquement la catégorie type Super, Hyper, Express, etc

Sachant que toute case contenant "Utile" contiendra forcément "Express" mais pas l'inverse.

Voici donc la formule que j'essaye :

=SI(NB.SI(D2;"*Hyper U*";"Hyper U";SI(D2;"*Super U*";"Super U";SI(D2;"*Marché*";"Marché U";SI(D2;"*Utile*";"Utile";"U Express")))))

Cela ne fonctionne pas et Excel m'indique que j'ai entré un nombre de caractères trop important... Y a t il une possibilité pour qu'une formule puisse traiter 5 arguments de contenance ?

Je vous remercie beaucoup pour votre aide providentielle !

4 réponses

via55
Messages postés
13595
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 mai 2022
2 401
5 déc. 2017 à 19:45
Bonsoir

Tu peux bien sur imbriquer plus de 5 Si mais ce qui pose problème dans ta formule c'est le NB.SI qui ne sert à rien ce devrait être :
=SI(D2;"*Hyper U*";"Hyper U";SI(D2;"*Super U*";"Super..;etc

Cdlmnt
Via
3
FormulaSeeker
Messages postés
13
Date d'inscription
mardi 5 décembre 2017
Statut
Membre
Dernière intervention
5 mars 2018

6 déc. 2017 à 10:46
Bonjour,

Un grand merci d'avoir pris le temps de me répondre !

Excellente journée à vous !
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 253
7 déc. 2017 à 16:05
Salut Via, comment va?
es tu sur que ta formule fonctionne, avec un code SI qui n'utilise pas d'opérateur. Si, oui, dis moi comment, ça m'interèsse!
crdlmnt
0