Calculer le nombre de cellule contenant un texte

Résolu/Fermé
Ladrian - 26 déc. 2016 à 15:48
 Celya83 - 27 avril 2020 à 11:29
Bonjour,

Je souhaite calculer le nombre de cellule contenant un texte particulier.

Mes données: une colonne de milliers de lignes. sur chaque ligne il y à un texte avec plus ou moins de caractère.

Ce que je veux c'est pouvoir compter le nombre de cellule ou apparaît un fragment de texte précis.

ex:

A1: chien_rouge
A2: chat_noir
A3: ours_jaune
A4: cheval_blanc
A5: panthere_rose
etc...

Si je demande NB.SI(A1:A5; "ch" ) je veux que ça me dise = 3
ou NB.SI(A1:A5; "an") = 2

J'ai essayé la formule NB.SI(plage; "texte"), mais ça ne me compte que les cellule contenant uniquement le "texte".
J'ai essayé NB.SI(plage; "*texte*") mais ça ne fonctionne pas non plus

auriez vous une idée de comme faire???
A voir également:

3 réponses

Raymond PENTIER Messages postés 58438 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 16 mai 2024 17 109
26 déc. 2016 à 22:57
Bonjour ladrian.

Tu as un gros problème quelque part !
La formule =NB.SI(A1:A5; "*ch*") donne bien 3 ...
La formule =NB.SI(A1:A5; "*an*") donne bien 2 ...
11
Bonjour Raymond,
J'ai réessayé avec les mots chat, chien, etc... et la formule avec les astérisques, mais ça ne fonctionne pas...

est ce que cela vient de la version de libre office? (je travail sous Libreoffice 4.3)
Je comprends vraiment pas ce qu'il se passe
0
yclik Messages postés 3604 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 13 mai 2024 1 483 > Ladrian
27 déc. 2016 à 12:07
Bonjour
voir dans l'aide le traitement des expressions régulières dans les options
0
Rebonjour,
je viens d'essayer avec une feuille de calcul dans google drive et ça fonctionne très bien, je pense donc que c'est la feuille de calcul initial qui est corrompu, ou la version de libreoffice qui bug.

merci pour votre aide!
0
shunesburg69 Messages postés 1057 Date d'inscription vendredi 23 mars 2007 Statut Membre Dernière intervention 26 février 2020 215 > Ladrian
Modifié par shunesburg69 le 27/12/2016 à 12:39
Tu as LibreOffice 4.3 ? Cette version est super vieille, il faut que tu mettes à jour.
Actuellement la dernière version de LibreOffice est la 5.2.4, peut-être que ton problème sera résolu avec une mise à jour :
https://fr.libreoffice.org/download/telecharger-libreoffice/
0
Merci, merci, pratique et j'avais zappé la formule
0