Calculer le nombre de cellule contenant un texte [Résolu/Fermé]

Signaler
-
 Celya83 -
Bonjour,

Je souhaite calculer le nombre de cellule contenant un texte particulier.

Mes données: une colonne de milliers de lignes. sur chaque ligne il y à un texte avec plus ou moins de caractère.

Ce que je veux c'est pouvoir compter le nombre de cellule ou apparaît un fragment de texte précis.

ex:

A1: chien_rouge
A2: chat_noir
A3: ours_jaune
A4: cheval_blanc
A5: panthere_rose
etc...

Si je demande NB.SI(A1:A5; "ch" ) je veux que ça me dise = 3
ou NB.SI(A1:A5; "an") = 2

J'ai essayé la formule NB.SI(plage; "texte"), mais ça ne me compte que les cellule contenant uniquement le "texte".
J'ai essayé NB.SI(plage; "*texte*") mais ça ne fonctionne pas non plus

auriez vous une idée de comme faire???

3 réponses

Messages postés
51991
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 juillet 2020
13 726
Bonjour ladrian.

Tu as un gros problème quelque part !
La formule =NB.SI(A1:A5; "*ch*") donne bien 3 ...
La formule =NB.SI(A1:A5; "*an*") donne bien 2 ...
6
Merci

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez Comment Ça Marche

CCM 57840 internautes nous ont dit merci ce mois-ci

Bonjour Raymond,
J'ai réessayé avec les mots chat, chien, etc... et la formule avec les astérisques, mais ça ne fonctionne pas...

est ce que cela vient de la version de libre office? (je travail sous Libreoffice 4.3)
Je comprends vraiment pas ce qu'il se passe
Messages postés
2054
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
24 juillet 2020
777 > Ladrian
Bonjour
voir dans l'aide le traitement des expressions régulières dans les options
Rebonjour,
je viens d'essayer avec une feuille de calcul dans google drive et ça fonctionne très bien, je pense donc que c'est la feuille de calcul initial qui est corrompu, ou la version de libreoffice qui bug.

merci pour votre aide!
Messages postés
1057
Date d'inscription
vendredi 23 mars 2007
Statut
Membre
Dernière intervention
26 février 2020
112 > Ladrian
Tu as LibreOffice 4.3 ? Cette version est super vieille, il faut que tu mettes à jour.
Actuellement la dernière version de LibreOffice est la 5.2.4, peut-être que ton problème sera résolu avec une mise à jour :
https://fr.libreoffice.org/download/telecharger-libreoffice/
Merci, merci, pratique et j'avais zappé la formule
Messages postés
1057
Date d'inscription
vendredi 23 mars 2007
Statut
Membre
Dernière intervention
26 février 2020
112
NB.SI(plage;"ch*")

N'ayant rien avant si tu mets l'astérisque avant LibreOffice ne prendra pas en compte les mots commençant directement par "Ch" et n'ayant rien avant.
LibreOffice est la meilleur alternative à Microsoft Office. C'est pas pour rien que LibreOffice est par défaut dans la quasi totalité des distributions Linux.
Bonsoir,
Merci pour ta réponse

j'ai essayé avec une astérisque uniquement avant ou après et une astérisque avant et après, mais ça ne fonctionne pas.
et dans la grande majorité des cas, les mots ou expression que je recherche dans mon tableau ne sont pas au début ni à la fin du texte mais au milieu.
Messages postés
1057
Date d'inscription
vendredi 23 mars 2007
Statut
Membre
Dernière intervention
26 février 2020
112 > Ladrian
Tu as quelle version de LibreOffice ou Apache OpenOffice ?

Actuellement la dernière version de LibreOffice est la 5.2.4, peut-être que ton problème sera résolu avec une mise à jour :
https://fr.libreoffice.org/download/telecharger-libreoffice/
petit précision, je bosse sur libre office calc pour l'instant