RechercheV ne marche pas mais je ne vois pas pourquoi (#NA)

Résolu/Fermé
TOT127 Messages postés 898 Date d'inscription mercredi 8 avril 2009 Statut Membre Dernière intervention 7 août 2018 - 8 juil. 2017 à 11:48
TOT127 Messages postés 898 Date d'inscription mercredi 8 avril 2009 Statut Membre Dernière intervention 7 août 2018 - 11 juil. 2017 à 12:43
Coucou,
dans ce fichier, il me semble ne pas avoir fait d'erreurs avec la formule RechercheV (feuille "All"), et pourtant j'obtiens une erreur. Ca ne m'est jamais arrivé, enfin ça m'arrivait quand je ne savais pas faire de RechercheV
http://www.cjoint.com/c/GGijV7Tl1LY
Le fichier contient des macros apparement, est ce le prb?
merci!
A voir également:

2 réponses

PapyLuc51 Messages postés 4342 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 15 juin 2024 1 421
11 juil. 2017 à 07:10
Bonjour

1/ A ma première réponse je n'avais pas été plus loin que la cellule B2 de "All" mais en complétant tout la colonne les cellules qui n'ont pas de correspondance chiffrée donnent #N/A. J'ai donc ajouter la condition SIERREUR() à la formule précédemment donnée.

=SIERREUR(RECHERCHEV($A2;'2009'!$B:$C;2;FAUX);"")

2/ J'ai aussi complété les calculs dans "All" et j'ai remarqué quelques anomalies dues à l'ajout d'un espace après certains noms dans la colonnes B de tous les feuillets. Pour éviter ce genre de problème il serait bon d'installer sur les futurs ajouts de feuillets une liste déroulante basée sur la colonne B de "All".

Ton fichier ainsi complété en retour

https://www.cjoint.com/c/GGlfjKImzJv

Cordialement
0
TOT127 Messages postés 898 Date d'inscription mercredi 8 avril 2009 Statut Membre Dernière intervention 7 août 2018 96
11 juil. 2017 à 12:43
merci, je regarde ça
0