Combiné si, rechercheV et contient [Fermé]

Signaler
-
Messages postés
25949
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
-
Bonjour,

Je souhaite faire une formule de la façon suivante :

si (rechercheV contient "test" alors formule 1 sinon formule 2).

Mais lorsque j'écris :

si(rechercheV(...;...;...)="*test*";formule1; formule2) cela me renvoie une erreur.

A priori cela vient du ="*test*" .

2 réponses

Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
64
Bonjour ,

tu devrais plutôt faire :

=SI(NB.SI(rechercheV(...;...;...);"*test*"); formule1; formule2)

Cdlt

Nos seules limites sont celles que nous nous imposons nous-même.
La politesse et un merci ne tuent pas. Il existe un bouton pour "Résolu" pour confirmer que     votre problème n'en est plus un. Fahora
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
64
Pardon , petite erreur :

Utilise la fonction "TROUVE"

=SI(TROUVE("test";RECHERCHEV(...;...;...;Faux))>=1;formule1;formule2)

Le >= 1 implique que le mot peut être écrit plusieurs fois dans la recherche
Messages postés
12984
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
8 avril 2021
2 168
Bonjour

Je ne sais pas ce qu'il y a comme 1er critère dans ta recherchev mais le résultat renvoyé est ce qui correspond exclusivement à ce critère

Si avec recherchev tu recherche la 1ere ligne contenant test ta formule devrait plutôt être du style :
=SI(ESTERREUR(RECHERCHEV("*test*";B3:C20;2;0));form1;form2)

Cdlmnt
Via
Messages postés
25949
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
5 865
Bonjour (et salut les copains)
je proposeraispour être sur que test soit bien dans la valeur trouvée par je ne sais quelle formule de recherche, et pas n'importe où dans la colonne:

=SI(NB.SI(RECHERCHEV(valeur;champ;colonne;0);"*test*");formule1;formule)

qui appliquera la formule 1 si la valeur trouvée content test, sinon la formule 2
c'est du moins comme ça que j'ai compris la question

;; et qui, à la réflexion, ne doit pas être loin de la bonne proposition de Fahora à 14h05 :-)))

(dont on ne sait pas pourquoi il'a corrigé pour une mauvaise, car TROUVE se met en erreur si le texte n'existe pas dans la cellule, mais ne comptera jamais le nombre de "test" dans un même texte)
trouve renvoie seulement le rang dans le texte du 1° caractère trouvé selon le mot cherché et uniquement si il y est écrit!

crdlmnt