Comparer 2 listes de 2 colonnes sur excel

Résolu/Fermé
fiofio86 Messages postés 1 Date d'inscription mercredi 4 juillet 2007 Statut Membre Dernière intervention 24 octobre 2007 - 4 juil. 2007 à 12:22
 KarlderG - 24 mai 2018 à 13:36
Bonjour,

Je vous solicite pour le probléme suivant :

Dans une feuille d'un classeur excel, je suis souhaite comparer deux données :

Il s'agit en fait de comparer deux listes de Nom et Prénon ( 600 noms environs)

La liste1 : En colonne A, les Noms et en colone B les prénoms
La liste 2 : En colonne C , les nons' et en colone D les prénoms'

A B C D
Martin Rémi Boucher Marie
Dupond Paul Morin Gérard
Dupuis Alex Renaud Jacques
fournier Pierre Girard Emilie
jacquet Guillaume Martin Rémi

Le but de ma recherche est de visualiser quelles personnes sont présentes dans la liste 1 et dans la liste 2 (exemple : Martin Rémi)

Existe t'il une macro me permettant de faire cette recherche rapidement ?

Merci d'avance à tous ceux qui pourront répondre rapidement à cette demande

cdt,
A voir également:

9 réponses

La fonction RECHERCHEV est la bonne solution !
Merci.

Exemple :
J'ai deux colonnes A et B, que je dois comparer.
Je veux savoir si une valeur de A est présente dans B.

1 - Je colle le contenu de la colonne B dans la "Feuil2" (vide) en première colonne.
2 - Je crée une colonne vide (C) dans la "Feuil1"
3 - Dans la première cellule de la colonne C, j'écris la formule =RECHERCHEV(A1;Feuil2!$1:$65536;1;FAUX)
4 - J'étire la cellule C1 vers le bas du tableau (Saisir le coin inférieur droit) pour que la formule s'applique à suffisamment de lignes.
5 - je patiente... et c'est OK !
6 - Je filtre les cellules ne contenant pas #N/A

Par contre, attention aux cellules fusionnées qui renverront #N/A même si les valeurs sont identiques.
141
Merci... !!!!!
0
julienprn Messages postés 28 Date d'inscription vendredi 23 avril 2010 Statut Membre Dernière intervention 2 septembre 2010 4
4 août 2010 à 16:54
je n'arrive pas a utiliser ta formule, ça me met du N/A partout grrrrr
2
ludoranv Messages postés 104 Date d'inscription samedi 29 juillet 2006 Statut Membre Dernière intervention 10 juin 2010 5
7 sept. 2010 à 15:12
Excellente solution simple et qui fonctionne (contrairement aux autres...)
0
Merci !!!!!
0
merci bcp ça marche
0